Closed Bug 1095087 Opened 7 years ago Closed 7 years ago

[MMS] Notification text does not display when viewing an image via Messages

Categories

(Firefox OS Graveyard :: Gaia::System::Window Mgmt, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(b2g-v2.1 affected, b2g-v2.2 affected)

RESOLVED DUPLICATE of bug 1072874
Tracking Status
b2g-v2.1 --- affected
b2g-v2.2 --- affected

People

(Reporter: smiko, Unassigned)

References

()

Details

(Whiteboard: [2.1-Daily-Testing])

Attachments

(1 file)

Attached file MMS.txt
Description: When the user views an image via Messages, notification text does not display.

Repro Steps:
1: Update a Flame to 20141106001204
2: Open > Messages > Create New Message > paper clip icon > gallery > select an image
3: From another device send an SMS.

Actual: Notification text is NOT displayed.

Expected: Notification text IS displayed

Device: Flame 2.1 (319mb/shallow flash)
BuildID: 20141106001204
Gaia: 9658b93b412bdcc0f953d668e8c8e68318c99fb8
Gecko: 76880403db44
Gonk: v188 (shallow flash)
Version: 34.0 (2.1)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Notes:
1: This issue only occurs when in the same message thread as the sending device. 
2: This issue also occurs when viewing a previously sent or received image.
3: When this issue occurs, the vibration and sound of the notification is heard, but no text is displayed. 
4: When the user returns to the message thread, a message is displayed informing them that they have a new message.

Repro frequency: 5/5

See attached: logcat

Video clip: http://youtu.be/eiJzLp77kXY
This issue DOES repro on Flame 2.2 (319mb/shallow flash)

Actual result: Notification text is NOT displayed.

Device: Flame 2.2
BuildID: 20141105040206
Gaia: 7c9e7cabbde941b976e0e40a3a1d94e21aa9c5e9
Gecko: 62990ec7ad78 
Version: 36.0a1 (2.2)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Whiteboard: [2.1-Daily-Testing]
It's _exactly_ like bug 1072874: "document.hidden"  stays to "false" when launching an activity that hides SMS. This is really wrong in my opinion.

If we want to fix this bug without any change in System, we'd have to track if an activity is happening. I'd really want to avoid this :/

NI alive
Component: Gaia::SMS → Gaia::System::Window Mgmt
Flags: needinfo?(alive)
Ya it's the same thing; please push platform folks to work on bug 892371 more actively.
Flags: needinfo?(alive)
Depends on: 892371
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1072874
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)
Depends on: 1144132
You need to log in before you can comment on or make changes to this bug.