Check for constness of usable_ptr in configure

RESOLVED DUPLICATE of bug 1083116

Status

()

Core
Build Config
RESOLVED DUPLICATE of bug 1083116
3 years ago
3 years ago

People

(Reporter: rillian, Assigned: rillian)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

We don't build with more android ndk > v8 because the usable_ptr has become const in later, but memory/build/malloc_decls.h only checks the android SDK version.

Instead we should check for this in configure so we don't have to guess with targets are which.
(Assignee)

Comment 1

3 years ago
Created attachment 8518412 [details] [diff] [review]
Use a configure check for constness of usable_ptr_t
Assignee: nobody → giles
(Assignee)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1083116
You need to log in before you can comment on or make changes to this bug.