Closed Bug 1095281 Opened 5 years ago Closed 5 years ago

control-f5 refresh removes data from appcache, breaking subsequent visits

Categories

(Core :: Networking: Cache, defect)

33 Branch
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla36

People

(Reporter: thorne, Assigned: mayhemer)

References

Details

(Keywords: reproducible, testcase)

Attachments

(2 files)

618 bytes, application/x-zip-compressed
Details
v1
875 bytes, patch
michal
: review+
Details | Diff | Splinter Review
Attached file example.zip
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/38.0.2125.111 Safari/537.36

Steps to reproduce:

Create a simple html page with a cache manifest
view it
check about:cache to verify pages are cached
refresh with ctrl-f5 - page displays correctly
note in about:cache, the html file is still listed, but now has data size of 0 bytes
refresh page with normal f5, get an "Offline mode" error

See example.zip to reproduce. Extract and visit "test.html". (on a server - appcache does not apply when opening from the file system)


Actual results:

Page shows an error - "Firefox is currently in offline mode and can't browse the Web."


Expected results:

Not sure, I don't know if ctrl-f5 behavior is standardized. But certainly not this.
FF version is 33.0.3
UA: "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0"
This reproduces on beta as well.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 7 → All
Product: Firefox → Core
Hardware: x86_64 → All
... and Nightly! Honza, can you have a look? :-)
Component: Untriaged → Networking: Cache
Flags: needinfo?(honzab.moz)
Attached patch v1Splinter Review
Thanks for the test case!  I forgot to duplicate this code in the new cache code as well.
Assignee: nobody → honzab.moz
Status: NEW → ASSIGNED
Flags: needinfo?(honzab.moz)
Attachment #8521528 - Flags: review?(michal.novotny)
Attachment #8521528 - Flags: review?(michal.novotny) → review+
https://hg.mozilla.org/mozilla-central/rev/a1e78007197e
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla36
Duplicate of this bug: 1123150
You need to log in before you can comment on or make changes to this bug.