Closed Bug 1095334 Opened 6 years ago Closed 6 years ago

The background (blue area) position of selection area is not correct in vertical-(lr/rl) writing mode

Categories

(Core :: Layout: Text and Fonts, defect)

x86_64
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla37

People

(Reporter: siqinbilige, Assigned: jfkthame)

Details

Attachments

(3 files)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0
Build ID: 20141105223254

Steps to reproduce:

select some text in div area in vertical(lr/rl) writing mode.



Actual results:

The background(blue aera) position of selection area is not correct.



Expected results:

It must be set to center of the text line.
Component: Untriaged → Layout: Text
Product: Firefox → Core
Does this still occur with the latest Nightly build, or is it now fixed?
This still occur with the latest Nightly build.
Attached image 1095334.png
Attached image 1095334-version.png
The problem here occurs because the 'vhea' table in Windows CJK fonts provides ascent/descent values that correspond to an alphabet baseline, but we align vertical text based on the centered baseline (except when text-orientation is sideways-right).
Status: UNCONFIRMED → NEW
Ever confirmed: true
Assignee: nobody → jfkthame
Status: NEW → ASSIGNED
Summary: The background(blue aera) position of selection area is not correct in vertical(lr/rl) writing mode → The background (blue area) position of selection area is not correct in vertical-(lr/rl) writing mode
Attachment #8542134 - Flags: review?(smontagu) → review+
https://hg.mozilla.org/mozilla-central/rev/1e64da07365b
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.