[Flame][Music]It will stop playing the song with its total time messed up after you dragging the seek icon to the end of progress bar.

RESOLVED FIXED

Status

defect
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: yulan.zhu, Assigned: dkuo)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.0 affected, b2g-v2.1 affected, b2g-v2.2 verified, b2g-master verified)

Details

Attachments

(8 attachments)

(Reporter)

Description

5 years ago
[1.Description]:
It will stop playing the song with its total time messed up  after you dragging the seek icon to the end of progress bar.
Attach logcat:logcat.txt.
Attach video:Video.mp4.
Attach testfile:test file.mp3.
Occurrence time:18:42

[2.Testing Steps]: 
1.Launch Music.
2.Switch to songs list.
3.Tap one song to play.
4.Drag the seek icon to the end of progress bar.

[3.Expected Result]: 
Should play the next song.

[4.Actual Result]: 
4.It will stop playing the song with its total time messed up.

[5.Reproduction build]: 
Gaia-Rev        ec722129a962704fda0dd5f39e7efd01261ae946
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/52280df0e39f
Build-ID        20141022160205
Version         32.0

[6.Reproduction Frequency]: 
occasionally Recurrence,5/10
(Reporter)

Comment 1

5 years ago
Posted file logcat
(Reporter)

Comment 2

5 years ago
Posted video Video.MP4
(Reporter)

Comment 3

5 years ago
Posted audio test file
(Reporter)

Comment 4

4 years ago
Posted file logcat.txt
Hi Hubert,
This bug can be repro on flame 2.0&2.1&2.2,
Could you help with this bug?
Thank you.

See the attachments: logcat.txt &Verify_1095382.MP4.
Occurrence rate:5/10
Occurrence time:17:10

Flame 2.0 version:
Gaia-Rev        ce83ea7b8e3fa2d1c3fd771fc22b654c18b3c381
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/4dd6d9b58f42
Build-ID        20141223000202
Version         32.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141223.034247
FW-Date         Tue Dec 23 03:42:58 EST 2014
Bootloader      L1TC00011880

Flame2.1 version:
Gaia-Rev        17c7ad2e4919a994f0844239b483116090412dee
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/39dfb662c82a
Build-ID        20141223001203
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141223.035107
FW-Date         Tue Dec 23 03:51:18 EST 2014
Bootloader      L1TC00011880

Flame 2.2 version:
Gaia-Rev        c2da2bafd4e809317e2ca70c9bf5c11136a32818
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/0532f2509f3f
Build-ID        20141223010202
Version         37.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141223.043429
FW-Date         Tue Dec 23 04:34:39 EST 2014
Bootloader      L1TC00011880
Flags: needinfo?(hlu)
(Reporter)

Comment 5

4 years ago
Posted video Verify_1095382.MP4
(Reporter)

Updated

4 years ago
Summary: [Flame][v2.0][Music]It will stop playing the song with its total time messed up after you dragging the seek icon to the end of progress bar. → [Flame][Music]It will stop playing the song with its total time messed up after you dragging the seek icon to the end of progress bar.
Hi Dominic, Could you help to check this, the timer on slider is showing strange value, thanks
Flags: needinfo?(dkuo)
(Assignee)

Comment 7

4 years ago
I took a quick test and looks like this issue is only reproducible if we seek to the end of the progress bar. I guess the the value we got from the progress bar might larger than the audio element's duration then breaks it, need some tests to confirm it and I will update here.
(Assignee)

Comment 8

4 years ago
Bug 1116839 also has a same screenshot(attachment 8543052 [details]) and looks like they are the same issue, probably related to KitKat?
Flags: needinfo?(dkuo) → needinfo?(yulan.zhu)
(Assignee)

Updated

4 years ago
See Also: → 1116839
(Reporter)

Comment 9

4 years ago
Hi Dominic,

Yes, this issue and bug 1116839 are the same problem, and has no relation with KitKat.
Flags: needinfo?(yulan.zhu) → needinfo?(dkuo)

Updated

4 years ago
Duplicate of this bug: 1116839
Triage on 1/7

Blocking Reason: Screenshot in comment 6 shows bad user experience and even if it happens when we seek to end of progress bar.
blocking-b2g: --- → 2.2+
(Reporter)

Comment 12

4 years ago
Ignore Comment 9.
This issue and bug 1116839 are the same problem.
And the issue is found on Flame-KK.
 (In reply to Lancy from comment #9)
> Hi Dominic,
> 
> Yes, this issue and bug 1116839 are the same problem, and has no relation
> with KitKat.
Flags: needinfo?(hlu)
(Assignee)

Updated

4 years ago
Assignee: nobody → dkuo
Flags: needinfo?(dkuo)
(Assignee)

Comment 13

4 years ago
Posted file patch
After tested 2.0, 2.1 and master, I found this should be an gecko issue, probably a gecko regression because it looks like if we set the audio's currentTime to a value which is the same as the audio's duration, then the audio element will just corrupt and does not play any more, unless we set a new src to the audio element then play it.

Jim, would you please review this first? I will file a new bug to notify the gecko devs and if we need this gaia patch, we can land it before gecko fixes it, thanks.
Attachment #8545838 - Flags: review?(squibblyflabbetydoo)
(Assignee)

Updated

4 years ago
Depends on: 1119186
Comment on attachment 8545838 [details] [review]
patch

This seems like a sane workaround, but a comment explaining things would be nice. Of course, if we fix the Gecko bug, that won't matter.
Attachment #8545838 - Flags: review?(squibblyflabbetydoo) → review+
(Assignee)

Comment 15

4 years ago
(In reply to Jim Porter (:squib) from comment #14)
> Comment on attachment 8545838 [details] [review]
> patch
> 
> This seems like a sane workaround, but a comment explaining things would be
> nice. Of course, if we fix the Gecko bug, that won't matter.

Thanks Jim, I often forget to add a comment to record bugs like this and thanks for reminding! I will add it then probably land it first because gecko fix usually takes time and people would like this blocker fixed.
QA Whiteboard: [COM=Gaia::Music]
(Assignee)

Comment 16

4 years ago
master: https://github.com/mozilla-b2g/gaia/commit/94a07d77c19531a84624205685aaab2a3718b5f1
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Comment 17

4 years ago
Comment on attachment 8545838 [details] [review]
patch

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Bug 1119186.
[User impact] if declined: the music player will become corrupted and cannot be used.
[Testing completed]: yes, with manual test.
[Risk to taking this patch] (and alternatives if risky): low.
[String changes made]: none.
Attachment #8545838 - Flags: approval-gaia-v2.2?
Attachment #8545838 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
This issue STILL reproduces on Flame 2.2 and Master.

Result: 
2.2 - Sometimes the music does not play the next song, and the elapsed time appears to be broken. Repro Rate: 4/12
3.0 - The player always plays the next song, but sometimes the elapsed time appears to be broken. Repro Rate: 3/12
 
Device: Flame 2.2 (319mb, full flash)
Build ID: 20150126002536
Gaia: 0518f4581a0925c0b703d730ef289ab15cbd1216
Gecko: c6aa604a7967
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Device: Flame Master (319mb, full flash)
Build ID: 20150126010231
Gaia: 0f662dffef27599443cfcd790c2b39190a2b35c8
Gecko: fa91879c8428
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0
QA Whiteboard: [COM=Gaia::Music] → [COM=Gaia::Music][QAnalyst-Triage?][
Flags: needinfo?(ktucker)
QA Whiteboard: [COM=Gaia::Music][QAnalyst-Triage?][ → [COM=Gaia::Music][QAnalyst-Triage?][failed-verification]
QA Whiteboard: [COM=Gaia::Music][QAnalyst-Triage?][failed-verification] → [COM=Gaia::Music][QAnalyst-Triage+][failed-verification]
Flags: needinfo?(ktucker)
Posted video video
This problem is verified pass on latest build of Flame2.2 and Flame3.0
See attachments: Verify_video.mp4
Rate: 0/10

Flame 2.2 build (319mb):
Build ID               20150227002521
Gaia Revision          eb6a5ac9081d3962198e0f4520b0743d716d7a27
Gaia Date              2015-02-26 17:25:22
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/c8a38dcfbebc
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150227.035943
Firmware Date          Fri Feb 27 03:59:54 EST 2015
Bootloader             L1TC000118D0

Flame 3.0 build (319mb):
Build ID               20150227010229
Gaia Revision          7512026a377271a0cade12d70846557f0bc7781c
Gaia Date              2015-02-26 19:06:40
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/c7968255c1ea
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150227.044026
Firmware Date          Fri Feb 27 04:40:36 EST 2015
Bootloader             L1TC000118D0
QA Whiteboard: [COM=Gaia::Music][QAnalyst-Triage+][failed-verification] → [COM=Gaia::Music][QAnalyst-Triage+][failed-verification][MGSEI-Triage+]

Updated

4 years ago
See Also: → 1173287
You need to log in before you can comment on or make changes to this bug.