The uppercase key pop would show lowercase when it is disappearing

VERIFIED FIXED in 2.2 S1 (5dec)

Status

defect
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: rudyl, Assigned: rudyl)

Tracking

({regression})

unspecified
2.2 S1 (5dec)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified)

Details

Attachments

(1 attachment)

46 bytes, text/x-github-pull-request
timdream
: review+
timdream
: feedback+
Details | Review
STR
===
1. Launch the keyboard and keep it in uppercase mode.
2. Tap on a key, like 'I' to make key popup show.
3. Release the key and see the popup is fading out.
   => At the same time, you would see lowercase popup.

--
Should be a regression.
Posted file Patch V1
This patch should be able to solve this regression.
However, I kind-of re-introduce the '{upperCase: true}' option back to the highlight() method, which I remember we removed before.

This is the best way I can think of, so set feedback? first to see if you agree this is a proper fix.
Thanks.
Attachment #8525983 - Flags: feedback?(timdream)
This would depends on the patch bug 1100777.
Assignee: nobody → rlu
Status: NEW → ASSIGNED
Depends on: 1100777
Comment on attachment 8525983 [details] [review]
Patch V1

Looks good, thank you. The only improvement I could ask for is to use css classes to toggle visibility, instead of set an inline style

https://github.com/RudyLu/gaia/commit/4f406f232d76c05a9961044ba0f3b9c13aaf8619#diff-dd9059d084d4eb39368074dbc7d87865R160
Attachment #8525983 - Flags: feedback?(timdream) → feedback+
Comment on attachment 8525983 [details] [review]
Patch V1

Patch updpated to address the review comments and add tests.
Also did some cleanup for the setUpperCase API of LayoutPageView.

Tim, please help review it.
Thanks.
Attachment #8525983 - Attachment description: WIP → Patch V1
Attachment #8525983 - Flags: review?(timdream)
Comment on attachment 8525983 [details] [review]
Patch V1

Please read Github comment. We should let the CSS do it's work if we could.
Attachment #8525983 - Flags: review?(timdream)
Comment on attachment 8525983 [details] [review]
Patch V1

Thanks for the advice, patch updated.
Could you please help review it again?
Attachment #8525983 - Flags: review?(timdream)
master,
https://github.com/mozilla-b2g/gaia/commit/fb700a6b518f68bdc4b619c5125f61aeb0b57b38

--
Thanks for the review!
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.2 S1 (5dec)

Comment 9

5 years ago
Verified the issue is fixed on 2.2 Flame

lowercase letter is no longer appears when uppercase letter is entered

Device: Flame 2.2 Master (KK 319Mb Shallow Flash)
BuildID: 20141125040209
Gaia: 824a61cccec4c69be9a86ad5cb629a1f61fa142f
Gecko: acde07cb4e4d
Version: 36.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
2.2+ all fixed regressions -- reset if disagree.
blocking-b2g: 2.2? → 2.2+
You need to log in before you can comment on or make changes to this bug.