All users were logged out of Bugzilla on October 13th, 2018

[Clock][System] System clock is not showing in status bar while any app is open

VERIFIED FIXED

Status

VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: safwan, Assigned: mancas)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.0 unaffected, b2g-v2.1 unaffected, b2g-v2.2 verified)

Details

(Reporter)

Description

4 years ago
# Open any application
# Check the status bar for the clock time

Actual result:
# There is no clock showing the time in the status bar

Expected result:
# There should be a clock to show the time in the status bar
(Reporter)

Comment 1

4 years ago
I believe its a regression because in the build of 1 week ago, I did not face it. So marking as qawanted and regression
Keywords: qawanted, regression
Component: Gaia::Clock → Gaia::System
Tested with Shallow Flash on 319mb using Engineering builds

This bug repro's on Flame KK builds: Flame 2.2 KK

Actual Results: Time is not displayed in the Status bar when any app is active on screen.

Repro Rate: 3/3

Environmental Variables:
Device: Flame 2.2 KK
BuildID: 20141107055645
Gaia: 779f05fead3d009f6e7fe713ad0fea16b6f2fb31
Gecko: 69198f0cc0bd
Version: 36.0a1 (2.2) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

-----------------------------------------------------------------
-----------------------------------------------------------------

This bug does NOT repro on Flame kk build: Flame 2.1 KK, Flame 2.0 KK

Actual Result: Time is correctly displayed in the Status bar even when apps are active.

Repro Rate: 0/5

Environmental Variables:
Device: Flame 2.1 KK
BuildID: 20141106184409
Gaia: 6295f6acfe91c6ae659712747dd2b9c8f51d0339
Gecko: 8c23b4f2ba29
Version: 34.0 (2.1) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
-----------------------------------------------------------------
Environmental Variables:
Device: Flame 2.0 KK
BuildID: 20141107024312
Gaia: d3e4da377ee448f9c25f908159480e867dfb13f3
Gecko: a41256642115
Version: 32.0 (2.0) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.0: --- → unaffected
status-b2g-v2.1: --- → unaffected
status-b2g-v2.2: --- → affected
Flags: needinfo?(jmitchell)
Keywords: qawanted
QA Contact: croesch
Blocking Nom:  Regression, broken functionality, bad UX (user should always be able to see the time)
blocking-b2g: --- → 2.2?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: regressionwindow-wanted
QA Contact: croesch
QA Contact: jmercado
Bug 1091483 seems to have been the cause for this issue.

B2g-inbound Regression Window

Last Working 
Environmental Variables:
Device: Flame 2.2
BuildID: 20141106225407
Gaia: 83eaaae5fc609aa414d27a13a0237acb2d647a3a
Gecko: 742640491a42
Version: 36.0a1 (2.2) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

First Broken 
Environmental Variables:
Device: Flame 2.2
BuildID: 20141106235807
Gaia: 99cd108ce3f9579997b13e43da18f81d18cfe5ab
Gecko: 741d8f9bcd7a
Version: 36.0a1 (2.2) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Last Working gaia / First Broken gecko - 
Gaia: 83eaaae5fc609aa414d27a13a0237acb2d647a3a
Gecko: 741d8f9bcd7a

First Broken gaia / Last Working gecko - 
Gaia: 99cd108ce3f9579997b13e43da18f81d18cfe5ab
Gecko: 742640491a42

Gaia Pushlog: https://github.com/mozilla-b2g/gaia/compare/83eaaae5fc609aa414d27a13a0237acb2d647a3a...99cd108ce3f9579997b13e43da18f81d18cfe5ab
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: regressionwindow-wanted
Broken by Bug 1091483 - Can you take a look Manuel?
Blocks: 1091483
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell) → needinfo?(b.mcb)
QA Contact: jmercado
(Assignee)

Comment 6

4 years ago
I'm working to fix Bug 1091483. This issue should be fixed today

Thanks for your patience
Flags: needinfo?(b.mcb)
blocking-b2g: 2.2? → 2.2+
Assignee: nobody → b.mcb
(Assignee)

Comment 7

4 years ago
Could you check the issue with the latest master branch?

Thanks!
Flags: needinfo?(jmitchell)
QA-Wanted: to check this in the latest Master
Flags: needinfo?(jmitchell)
Keywords: qawanted
Issue is fixed on latest master. Clock is showing when inside an app.

Device: Flame 2.2 Master
BuildID: 20141117050825
Gaia: ddf5b92f43ec27c93ad4fea4fd1207da8936b8e7
Gecko: 41586923b3bd
Version: 36.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
status-b2g-v2.2: affected → fixed
Flags: needinfo?(jmitchell)
Keywords: qawanted
Status: NEW → RESOLVED
Last Resolved: 4 years ago
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
Resolution: --- → FIXED

Comment 10

4 years ago
Verified the issue is fixed on 2.2 Master Flame

The System clock is shown in status bar while any app is open

Flame 2.2

Device: Flame 2.2 (319mb)(Kitkat Base)(Shallow Flash)
BuildID: 20141119040205
Gaia: e64428c5b2dce5db90b75a5055077a04f4bd4819
Gecko: bc2c36dda0a9
Version: 36.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
status-b2g-v2.2: fixed → verified
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.