Status

()

Core
Preferences: Backend
P3
enhancement
RESOLVED WONTFIX
17 years ago
11 years ago

People

(Reporter: gerv, Assigned: gerv)

Tracking

Trunk
Future
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Not sure where this should live...

I've decided it would be cool to implement a pref that you set to a string value
and another boolean pref to turn on a mode where every link you click has that
string value prepended to it.

For example, the boolean pref could be hooked up to a toolbar button, and the
URL could be:
http://www.google.com/search?q=cache:

:-) Google Cache Surfing :-)

The prepending needs to be done on line 2839 of
content/base/src/nsGenericElement.cpp .

  absURLSpec.InsertWithConversion("http://www.google.com/search?q=cache:" ,0);

But we need to set up a pref to hold the string, and a pref listener to listen
for changes in the boolean.

Gerv
I think I'll be doing this :-)

Gerv
Assignee: pchen → gerv
Severity: normal → enhancement
Priority: -- → P3
WAAH! WAAH! FEATURE CREEP ALERT! WAAH! WAAH!
Whiteboard: WONTFIX?
Oh, stop whingeing, hixie :-) I'm probably not going to get around to this for
ages, but it's a cool idea. And the amount of code required is probably about
20-30 lines of C++.

Gerv
Whiteboard: WONTFIX?

Comment 4

17 years ago
It sounds like a cool idea to me.  In addition to surfing Google's cache, this
could probably be used for translators like Babelfish, or that thing that
translates Web pages into pig latin.

Some people complain that Mozilla developers spend too much time throwing in
extra features that nobody really needs, instead of concentrating on making it
faster and more stable.  The problem with that argument is that I'm pretty sure
working on a cache-surfing feature isn't going to take anything away from your
other contributions to the project.  I doubt any of those complainers have
contributed to the project at all.

By the way, I've heard it said that any software project born at MIT would grow
until it reached the point that it could read mail.  Mozilla was always intended
to read mail (and currently does an admirable job of it) - you've got to keep
things in perspective. ;-)

This sort of thing should be hidden away in a dark corner of Preferences
somewhere, so the average user wouldn't see it unless they were really looking
for extra nifty toys to play with.

Comment 5

17 years ago
The problem with your argument is that additional features threaten stability
and speed, and therefore it does affect everyone involved.
Component: XP Apps → Preferences: Backend
QA Contact: sairuh → claudius

Comment 6

16 years ago
mark this bug dependent on bug 28586? Once bug 28586 is fixed,
placing a google link should be a breeze.
I stand by what I said in comment 2. This should be an XPI, not a part of Mozilla.
Target Milestone: --- → Future

Comment 8

16 years ago
*** Bug 195164 has been marked as a duplicate of this bug. ***

Comment 9

16 years ago
My bug 195164 has been marked as a duplicate of this bug, but this bug doesn't
mention the reason I wrote that bug so I'll copy the text here.  Basically, the
idea is to avoid 404 errors upon a site being Slashdotted -- it should
automatically try Google's cache, or archive.org.  Original comment follows:




If a site is down, Mozilla could pretty easily grab the google cache instead.
Or, if there's no google cache or if the cache matches the current page, check
archive.org. Mozilla could auto-generate a page offering the user some options.
Think about it - it would be the end of 404 errors. Instead of

          "404 The requested page could not be found."

you could get

          "The site you requested is currently down. Would you like to use
Google's cache [216.239.51.100] instead? I also have a snapshot of the page you
requested from August 12, 2002 [archive.org] but older ones are available here
[archive.org]."

(Lifted from a discussion at Slashdot,
http://developers.slashdot.org/comments.pl?sid=55236&cid=5391452 .)

Comment 10

14 years ago
(In reply to comment #9)
> automatically try Google's cache, or archive.org.

Funny. Marketing would say thats an USP (Unique Selling Proposition)
What about comment 3? Can it be done?
The way this would probably work would be as an extension. There's no UI, it's
just that if it detects that you are in the Google cache, it prepends the cache
lookup URL to any link you click. You break out either by typing a new URL,
going to a bookmark, or closing the window.

It could be called "Sticky Google Cache" or something like that.

Gerv

Comment 12

14 years ago
On eproblem with this is that with some sites the google cache page will not
load in mozilla if the original site is down.

For example mysql.com is down for me at the moment, this page is fine in lynx:

  http://www.google.co.uk/search?q=cache:www.mysql.com/downloads/mirrors.html

But in mozilla it is never loaded past the google table at the top.

I have remote images. javascript and css all turned off (webdev toolbar) and
still the page will not display.

Of course view source worts without a problem.

I have noticed this bug many times... I probably should have reported it before,
perhaps it should have it's own bug rather than be tacked onto this feature
request...  

Or perhaps it's something sill with the way I have mozilla set up...

I'm running the FC3 mozilla:

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20041020

Comment 13

14 years ago
*** Bug 274369 has been marked as a duplicate of this bug. ***
WONTFIX in favour of a greasemonkey script?
Shaver is right. We've moved on a bit since 2001 :-)

Gerv
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.