Closed Bug 1095744 Opened 7 years ago Closed 4 years ago

[Browser] The "Mozilla project" page in "Our Contributors" defaults to a foreign language

Categories

(Firefox OS Graveyard :: Gaia::Browser, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(b2g-v2.1 affected, b2g-v2.2 affected)

RESOLVED WONTFIX
Tracking Status
b2g-v2.1 --- affected
b2g-v2.2 --- affected

People

(Reporter: fmuyumba, Unassigned)

Details

(Whiteboard: [2.1-exploratory-3][systemsfe])

Attachments

(2 files)

Description:
When the User taps on "Mozilla project" link in "Our Contributors" the page that opens up, defaults to a foreign language 

Repro Steps:
1) Update a Flame device to BuildID: 20141107001205
2) Launch "Settings" > Tap on "Device information"
3) Tap on "Credits"
4) scroll down to the footer and tap on "Mozilla project"
5) Observe the language that is used

  
Actual:
The default language is foreign
  
Expected: 
English is the default language
  
Environmental Variables:
Device: Flame 2.1 (319mb)(Kitkat Base)(Shallow Flash)
BuildID: 20141107001205
Gaia: 6295f6acfe91c6ae659712747dd2b9c8f51d0339
Gecko: 8c23b4f2ba29
Version: 34.0
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
  
  
Repro frequency: 100%
See attached: video clip & logcat:
Flags: needinfo?(jmitchell)
Attached image 2014-11-07-13-57-02.png
[Blocking Requested - why for this release]: Wrong language, Poor UX
blocking-b2g: --- → 2.1?
Flags: needinfo?(jmitchell)
his issue is NOT reproducible on Flame 2.2 Master (319mb)(Kitkat Base)(Shallow Flash) 

Result: 
The default language of "Mozilla project" is English

Environmental Variables:
Device: Flame 2.2(319mb)(KitKat)(Shallow Flash)
BuildID: 20141105040206
Gaia: 7c9e7cabbde941b976e0e40a3a1d94e21aa9c5e9
Gecko: 62990ec7ad78
Version: 36.0a1 
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

----------------------------------------------------------------------------------------------------

Did NOT test the Flame 2.0 (319mb)(Kitkat Base)(Shallow Flash) because the feature does NOT exist

Environmental Variables:
Device: Flame 2.0 (319mb)(Kitkat Base)(Shallow Flash
BuildID: 20141107000206
Gaia: d3e4da377ee448f9c25f908159480e867dfb13f3
Gecko: 9836e9d81357 
Version: 32.0 
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
blocking-b2g: 2.1? → 2.1+
hi Gregor, please help to assign dev team to follow up.
Flags: needinfo?(anygregor)
Can we get a reverse regression-window?
Flags: needinfo?(anygregor)
QA Contact: ddixon
Issue DOES occur in the latest Flame 2.1, 2.2 build (Shallow Flash, tinderbox eng., 319 MB memory). 
The reproduction rate is intermittent (around 2/10).

Actual Results: Opening "Mozilla Project" tab opens a page that defaults in a foreign language. 

Device: Flame 2.1
BuildID: 20141113112008
Gaia: af6533781356acc62b0f40c9e040aa5b47d3b709
Gecko: 252a33e86472
Version: 34.0 (2.1)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
-----------------------------------------------------------
Device: Flame 2.2
BuildID: 20141112125016
Gaia: 65d593cdd9d88648045a30a63fc329b7bb5d340b
Gecko: 66cdb18f36da
Version: 36.0a1 (2.2)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
QA Contact: ddixon
Ted, can you try to see whats going on here?
Flags: needinfo?(tclancy)
Whiteboard: [2.1-exploratory-3] → [2.1-exploratory-3][systemsfe]
Why did we block on this?
Flags: needinfo?(bbajaj)
(In reply to Gregor Wagner [:gwagner] from comment #9)
> Why did we block on this?

I think in triage QA confirmed this to be a regression and its ugly for a foreign language popping up when viewing in English.
Flags: needinfo?(bbajaj)
Keywords: regression
(In reply to bhavana bajaj [:bajaj] from comment #10)
> (In reply to Gregor Wagner [:gwagner] from comment #9)
> > Why did we block on this?
> 
> I think in triage QA confirmed this to be a regression and its ugly for a
> foreign language popping up when viewing in English.

According to comment 4 its not a regression since the feature didn't exist before.
(In reply to Gregor Wagner [:gwagner] from comment #11)
> (In reply to bhavana bajaj [:bajaj] from comment #10)
> > (In reply to Gregor Wagner [:gwagner] from comment #9)
> > > Why did we block on this?
> > 
> > I think in triage QA confirmed this to be a regression and its ugly for a
> > foreign language popping up when viewing in English.
> 
> According to comment 4 its not a regression since the feature didn't exist
> before.

Sorry, I meant regression within 2.1 where this might have been working before (could be worng here as that was a comment noted in triage). I am fine to un-block it if you think this isn't critical or we could get someone else's(product,UX) opinion if unsure :)
In case it matters, the language that pops up when you click on the link is Italian.
(In reply to Marcia Knous [:marcia - use needinfo] from comment #13)
> In case it matters, the language that pops up when you click on the link is
> Italian.

For me at least, which is different than the screenshot.
Assignee: nobody → tclancy
Flags: needinfo?(tclancy)
(In reply to bhavana bajaj [:bajaj] from comment #12)
> (In reply to Gregor Wagner [:gwagner] from comment #11)
> > (In reply to bhavana bajaj [:bajaj] from comment #10)
> > > (In reply to Gregor Wagner [:gwagner] from comment #9)
> > > > Why did we block on this?
> > > 
> > > I think in triage QA confirmed this to be a regression and its ugly for a
> > > foreign language popping up when viewing in English.
> > 
> > According to comment 4 its not a regression since the feature didn't exist
> > before.
> 
> Sorry, I meant regression within 2.1 where this might have been working
> before (could be worng here as that was a comment noted in triage). 

This issue occurs on the earliest KK 2.1 build 

Device: Flame 2.1
Build ID: 20140904062538
Gaia: a47ecb6368c015dd72148acde26413fd90ba3136
Gecko: ffb144a500a4
Version: 34.0a2 (2.1)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
Keywords: regression
Unblocking. Not a regression, edge case, repros only 2 out of 10 times.
blocking-b2g: 2.1+ → ---
I did a build using the specified gaia and gecko versions, and I couldn't reproduce the problem. I got the English-language page 10 out of 10 times.

Is it possible this was a glitch on the server side?
(In reply to Ted Clancy [:tedders1] from comment #17)
> I did a build using the specified gaia and gecko versions, and I couldn't
> reproduce the problem. I got the English-language page 10 out of 10 times.
> 
> Is it possible this was a glitch on the server side?

When you hit a no-repro you have to restart (or maybe even factory reset) to 'try again' - the bug will not repro after a no-repro by just closing the page and re-selecting the link
Hmmm. I started resetting the phone between attempts, and I saw the German page twice in four attempts. One time, there was a header saying "Would you like to see this page in your language?".

I haven't seen the German page since then. I've tried about 20 times, including two re-flashings of the device. Odd.
Ya, Marcia saw it in Italian (comment 13) and when I saw it I'm pretty sure it was in Russian every time. Not sure why, Russian was certainly not anything my phone was set to recently and not my go-to language if needing to change from English.
Putting this back since it's no longer a blocker.
Assignee: tclancy → nobody
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.