[Loop] When you open contacts through Loop app, the header quickly changes after a moment

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
4 years ago
9 months ago

People

(Reporter: rmead, Unassigned, NeedInfo)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v2.0 unaffected, b2g-v2.1 affected, b2g-v2.2 affected)

Details

(Whiteboard: [2.1-exploratory-3], URL)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8519236 [details]
Flame2.1logcat.txt

Description:
While in a Loop app, if you tap the contacts icon on the bottom of the screen, when the contacts page opens, the header will quickly change.
   
Prereq:
Have the Loop app set up on device with 1 or more contacts saved

Repro Steps:
1) Update a Flame device to BuildID: 20141107001205
2) Tap the 'Firefox Hello' app
3) Tap contacts icon on the bottom of screen

  
Actual:
The page will load with the settings and quit icons to the right of the header text "Contacts" but will quickly disappear and the quit icon will appear to the left of the header text instead.
  
Expected: 
The page should load with the quit icon on the left side of the header text.
  

Flame 2.1(319mb)(KitKat)(Shallow Flash)

Environmental Variables:
Device: Flame 2.1
BuildID: 20141107001205
Gaia: 6295f6acfe91c6ae659712747dd2b9c8f51d0339
Gecko: 8c23b4f2ba29
Version: 34.0 (2.1)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
  
Notes: If you are currently in a call, the device is slowed down and the issue is more noticeable.
  
Repro frequency: 100%
See attached: logcat, video - http://youtu.be/I2NW3zwpELc
Flags: needinfo?(jmitchell)
(Reporter)

Comment 1

4 years ago
This issue also occurs on Flame 2.2(319mb)

When in loop app, if you open contacts via the icon on the bottom, when it loads, the header icons will quickly change.


Flame 2.2

Device: Flame 2.2 Master (319mb)(Kitkat Base)(Shallow Flash)
BuildID: 20141107040206
Gaia: 779f05fead3d009f6e7fe713ad0fea16b6f2fb31
Gecko: 64f4392d0bdc
Version: 36.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0


This issue does NOT occur on Flame 2.0(319mb)

While in loop app, if you open contacts via the icon on the bottom, the page will load without anything strange happening with the header.

Flame 2.0 

Device: Flame 2.0 (319mb)(Kitkat Base)(Shallow Flash)
BuildID: 20141107000206
Gaia: d3e4da377ee448f9c25f908159480e867dfb13f3
Gecko: 9836e9d81357 
Version: 32.0 (2.0)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
(Reporter)

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage?]
NI to loop owner to make a blocking call -
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell) → needinfo?(mbarone976)

Comment 3

9 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.