Closed Bug 1095768 Opened 5 years ago Closed 5 years ago

[Text Selection] Unable to paste into a blank text field

Categories

(Firefox OS Graveyard :: Gaia::SMS, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v2.2 affected)

RESOLVED DUPLICATE of bug 1098161
Tracking Status
b2g-v2.2 --- affected

People

(Reporter: smiko, Unassigned)

References

()

Details

(Whiteboard: [2.2-Daily-Testing])

Attachments

(1 file)

Attached file paste.txt
Description: The user must highlight text in order to paste. 

Repro Steps:
1: Update a Flame to 
2: Open Messages and type text.
3: Press down on the text to bring up the text selection menu.
4: Select paste.
5: Long press on the empty text field.

Actual: The text selection menu does NOT display.

Expected: The text selection displays and the user is able to paste from the clipboard.

Device: Flame 2.2 (319mb/shallow flash)
BuildID: 20141107073659
Gaia: 779f05fead3d009f6e7fe713ad0fea16b6f2fb31
Gecko: b62ccf3228ba 
Version: 36.0a1 (2.2)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Repro frequency: 5/5

See attached: logcat

Video clip: http://youtu.be/Wedl1dBTdmo
Step 1 above should read: 
1: Update a Flame to 20141107073659.

________________________________________________________________________________________________________

This issue does NOT repro on Flame 2.1 (319mb/shallow flash) as the text selection feature does not exist. 

Device: Flame 2.1
BuildID: 20141107001205
Gaia: 6295f6acfe91c6ae659712747dd2b9c8f51d0339
Gecko: 8c23b4f2ba29
Gonk: 
Version: 34.0 (2.1)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
_________________________________________________________________________________________________________

This issue DOES repro on yesterday's Flame 2.2 (319mb/full flash)

Actual result: The text selection menu does NOT display in a blank text box.

Device: Flame 2.2 (319mb/full flash)
BuildID: 20141106040207
Gaia: 068b9711277b06c7d633517f9e1fcb5624bb39b3
Gecko: a074c0112919
Version: 36.0a1 (2.2)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Whiteboard: [2.2-Daily-Testing]
Hey Gregor,

is the copy/paste functionality part of the System FE team?
Here it looks like contenteditable elements are not considered.
Flags: needinfo?(anygregor)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)
(In reply to Julien Wajsberg [:julienw] from comment #2)
> Hey Gregor,
> 
> is the copy/paste functionality part of the System FE team?
> Here it looks like contenteditable elements are not considered.

I believe thats Tim?
Flags: needinfo?(anygregor) → needinfo?(timdream)
Ni George and Morris for copy paste issue.

Since contenteditable element will insert <br> at the end, not sure if select all will also select the element and removed unexpectedly.
Flags: needinfo?(timdream)
Flags: needinfo?(mtseng)
Flags: needinfo?(gduan)
I think it relates to gecko. We should have caret in empty column and tap it to launch the bubble.
Flags: needinfo?(gduan) → needinfo?(pchang)
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(pchang)
Resolution: --- → DUPLICATE
Duplicate of bug: 1098161
Flags: needinfo?(mtseng)
You need to log in before you can comment on or make changes to this bug.