[2.0][Flame] Nov 7 2014 update causes phone to heat up on its own on standby on 3G and lose battery

RESOLVED WONTFIX

Status

Firefox OS
General
RESOLVED WONTFIX
4 years ago
3 months ago

People

(Reporter: kaustavdm, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
This is for 2.0 (latest release build). After OTA on Nov 7 on Flame, the device heats up on its own when on 3G, network conditions optimal. Battery keeps draining at about 1% per minute.

The only app running is the Email app, with synchronizations at 5 min interval for 3 emails, though this did not affect heating or battery drainage before.
(Reporter)

Updated

4 years ago
Keywords: qawanted
(Reporter)

Updated

4 years ago
Summary: [2.0][Flame] Nov 7 2014 update causes phone to heat up on its on when standby on 3G on and lose battery → [2.0][Flame] Nov 7 2014 update causes phone to heat up on its own on standby on 3G on and lose battery
(Reporter)

Updated

4 years ago
Summary: [2.0][Flame] Nov 7 2014 update causes phone to heat up on its own on standby on 3G on and lose battery → [2.0][Flame] Nov 7 2014 update causes phone to heat up on its own on standby on 3G and lose battery
Unable to reproduce this issue on Flame device after installing build# 20141107000206. 

Also, I tested the OTA update and installation from build 20141107000206 to 20141119000207

I allowed the 11/19 build to idle with the Email app synced every 5 minutes.  I observed no significant changes in battery life or the device heating-up after 30 minutes of testing. 

Device: Flame 2.0
BuildID: 20141119000207
Gaia: 1ede2666f1e6c1b3fd3b282011caf0cbc59544b0
Gecko: faa64077b0c2
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 32.0 (2.0)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
(Reporter)

Comment 2

4 years ago
Did you try it on 3G? I still face the issue on the same build ID: 20141119000207. Once again, can this be a regression caused by OTA updates?

Comment 3

4 years ago
I can confirm this bug. It only happens with 3g enabled. The phone gets hot in a while.

Comment 4

4 years ago
I have done some radio logs using:

# logcat -b radio

And I think I might have found something related to this. Once every few seconds, I obtain this bunch of errors:

-----
D/RIL     (  207): [SUB0] [UNSL]< RIL_REQUEST_UNSOL_OEM_HOOK_RAW {error: response is not supported}
D/RIL     (  207): [SUB0] [UNSL]< RIL_REQUEST_UNSOL_OEM_HOOK_RAW {error: response is not supported}
D/RIL     (  207): [SUB0] [UNSL]< RIL_REQUEST_UNSOL_RESPONSE_VOICE_NETWORK_STATE_CHANGED
D/RIL     (  207): [SUB0] [4168]> RIL_REQUEST_OPERATOR
D/RIL     (  207): [SUB0] [4169]> RIL_REQUEST_DATA_REGISTRATION_STATE
D/RIL     (  207): [SUB0] [4170]> RIL_REQUEST_VOICE_REGISTRATION_STATE
D/RIL     (  207): [SUB0] [4171]> RIL_REQUEST_QUERY_NETWORK_SELECTION_MODE
D/RIL     (  207): [SUB0] [4171]< RIL_REQUEST_QUERY_NETWORK_SELECTION_MODE {0}
D/RIL     (  207): [SUB0] [4170]< RIL_REQUEST_VOICE_REGISTRATION_STATE {1,0550,00d536ca,3,(null),(null),(null),0,(null),(null),1,(null),(null),0,1b7}
D/RIL     (  207): [SUB0] [4169]< RIL_REQUEST_DATA_REGISTRATION_STATE {1,0550,00d536ca,3,(null),20,(null),(null),(null),(null),(null)}
D/RIL     (  207): [SUB0] [UNSL]< RIL_REQUEST_UNSOL_RESPONSE_VOICE_NETWORK_STATE_CHANGED
D/RIL     (  207): [SUB0] [4172]> RIL_REQUEST_OPERATOR
D/RIL     (  207): [SUB0] [4173]> RIL_REQUEST_DATA_REGISTRATION_STATE
D/RIL     (  207): [SUB0] [4174]> RIL_REQUEST_VOICE_REGISTRATION_STATE
D/RIL     (  207): [SUB0] [4175]> RIL_REQUEST_QUERY_NETWORK_SELECTION_MODE
E/RILQ    (  310): (0/310): RIL[0][cmd-22(104)] qcril_cm_ss_convert_gsm8bit_alpha_string_to_utf8: Invalid parameters for GSM alphabet to UTF8 conversion, input len = 0
D/RIL     (  207): [SUB0] [4168]< RIL_REQUEST_OPERATOR {Movistar,,21407}
D/RIL     (  207): [SUB0] [4172]< RIL_REQUEST_OPERATOR {Movistar,,21407}
D/RIL     (  207): [SUB0] [4174]< RIL_REQUEST_VOICE_REGISTRATION_STATE {1,0550,00d536ca,3,(null),(null),(null),0,(null),(null),1,(null),(null),0,1b7}
D/RIL     (  207): [SUB0] [4175]< RIL_REQUEST_QUERY_NETWORK_SELECTION_MODE {0}
D/RIL     (  207): [SUB0] [4173]< RIL_REQUEST_DATA_REGISTRATION_STATE {1,0550,00d536ca,3,(null),20,(null),(null),(null),(null),(null)}
D/RIL     (  207): [SUB0] [UNSL]< RIL_REQUEST_UNSOL_SIGNAL_STRENGTH {[signalStrength=0,bitErrorRate=0,CDMA_SS.dbm=-1,CDMA_SSecio=-1,EVDO_SS.dbm=-1,EVDO_SS.ecio=-1,EVDO_SS.signalNoiseRatio=-1,LTE_SS.signalStrength=99,LTE_SS.rsrp=2147483647,LTE_SS.rsrq=2147483647,LTE_SS.rssnr=2147483647,LTE_SS.cqi=2147483647}
-----


I think the phone gets hot because of this error is constantly being repeated.
Some more relevant information:

As you see, my operator is Movistar, and this SIM is data-only, I can't do any calls using it. It is a contract for 3g-4g only.
Also, I must say I have 2 SIMs inserted: one is Movistar (data-only) and the other is Orange (calls only).

If there is some more information I can provide, please let me know.

Comment 5

4 years ago
I confirm this is also happening in 2.2 nightly.

Comment 6

4 years ago
I have found the trigger of this problem, finally.
It is dependant of the APN of your provider. With some APNs, the radio falls into a loop that makes the phone hot and consume the battery in less than 6h in stand by, but it does not happen with other APNs.

To illustrate this end, let me explain my situation, so you can further investigate where is the bug located:

My operator, Movistar, does have two different APNs that the user can choose. One is called "telefonica.es" and the other is "movistar.es". The default detected APN for Firefox OS is "telefonica.es", and that is the one that is selected just after you activate 3G data.
But, yesterday, I changed the default APN for all things to "movistar.es". After the change, now the phone consumes the battery normally and doesn't get hot. In fact, now I have more than 1 day of battery with 3G activated and some applications in the background (like Telegram).

Now the point is trying to discover what is the difference between the two APNs and why one of them makes the phone hot and why the other doesn't.
Please, don't blame the operator. For example, in my case "telefonica.es" APN is used by default by some other phones (like the iPhone), and they don't have this problem. So clearly it is a bug in FFOS.

There are also other APNs causing this problem. You can have a look here and see that this is not only a problem for Telefonica users, it happens with other operators too:

https://bugzilla.mozilla.org/show_bug.cgi?id=1020000

Comment 7

4 years ago
I have the problem but I have never started the radio.
I'm also having this issue on 188+2.2. I've downgraded to 180+2.1 but the problem remains.

My operator is TIM Brasil. As soon as I get battery I'll try to disable mobile data to check if that's the problem.

Comment 9

4 years ago
I rarely use mobile data, I still have the problem with 3G disabled. My operator is Free in France.

Comment 10

3 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.