Closed Bug 1095931 Opened 5 years ago Closed 5 years ago

[e10s] Moving the mouse out of the page doesn't clear hover state

Categories

(Core :: General, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1018639
Tracking Status
e10s ? ---

People

(Reporter: bmarsd, Unassigned)

Details

Attachments

(1 file)

Attached file Testcase
With e10s enabled, moving the mouse out of the browser window or into the browser chrome doesn't cause the <html> element to lose its hover state. Child elements still work fine - it's only the root <html> element that gets stuck. It works as expected with e10s disabled.
tracking-e10s: --- → ?
OS: Linux → All
After more testing, I don't think it's specific to <html> - if there's another window overlapping the page, moving the mouse into it will cause whatever element the mouse was in last to be stuck in its hover state. <html> is just the most obvious since it covers the whole page, so it always gets stuck.
Hardware: x86_64 → All
Summary: [e10s] <html> element never loses hover state → [e10s] Moving the mouse out of the page doesn't clear hover state
And this is also related to Bug 1018639
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1018639
(In reply to Brian Marshall from comment #0)
> Created attachment 8519456 [details]
> Testcase
> 
> With e10s enabled, moving the mouse out of the browser window or into the
> browser chrome doesn't cause the <html> element to lose its hover state.
> Child elements still work fine - it's only the root <html> element that gets
> stuck. It works as expected with e10s disabled.

wfm with bug bug 1018639.
Moving from Core::Untriaged to Core::General https://bugzilla.mozilla.org/show_bug.cgi?id=1407598
Component: Untriaged → General
You need to log in before you can comment on or make changes to this bug.