Closed Bug 1096019 Opened 5 years ago Closed 5 years ago

Some videos freeze when playing with MediaSourceExtensions enabled

Categories

(Core :: Audio/Video, defect)

35 Branch
x86_64
Windows 7
defect
Not set

Tracking

()

RESOLVED WONTFIX

People

(Reporter: jackwickham, Unassigned)

References

(Blocks 1 open bug)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0
Build ID: 20141107004008

Steps to reproduce:

Watch certain HTML5 videos such as https://www.youtube.com/watch?v=q7vlk2H-BKY with media.mediasource.enabled and media.mediasource.ignore_condecs set to true.
The MIME type of the video is 'video/mp4; codecs="avc1.640028"', and DASH is set to yes (137/140).
This occurs with multiple videos, but not all.


Actual results:

After about 5-10 seconds, the video playback will freeze but the audio will continue to play. "Stats for Nerds" says that the video is still buffering, but the buffer bar no longer continues to increase.
This occurs every time I play the video.
I have reproduced this issue in the aurora and developer branches of firefox (I have no addons in the developer edition, so it's not an addons issue).



Expected results:

The video should play without interruption, like it does in Chrome.
probably a dupe of bug 1089937
Component: General → Video/Audio
Interestingly, the video referenced in bug 1089937 works fine for me (up to 1 minute, I didn't watch the whole thing) and appears to be using the VP9 codec.
Also, that bug is regarding audio and video stopping, whereas with this, only the video stops. It's probably still related though, just different symptoms.
Flags: needinfo?(cpearce)
Someone on the MSE team should triage this.
Flags: needinfo?(cpearce)
Set media.mediasource.enabled to false to disable it. This should be the default on 35 so feel free to re-open this bug if it is not disabled by default.
Blocks: MSE
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.