Closed Bug 1096025 Opened 5 years ago Closed 5 years ago

Sent emails are not marked as read

Categories

(Firefox OS Graveyard :: Gaia::E-Mail, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v2.0 unaffected, b2g-v2.1 verified, b2g-v2.2 verified)

VERIFIED FIXED
Tracking Status
b2g-v2.0 --- unaffected
b2g-v2.1 --- verified
b2g-v2.2 --- verified

People

(Reporter: gerard-majax, Assigned: asuth)

References

Details

Attachments

(1 file)

This is reproducing on my devices for a couple of weeks. It's not a very big issue, it's just highly disturbing. All devices and multiple email providers.

STR:
 0. Send an email

Expected:
 The email is copied to the Sent folder of the account, and marked as read.

Actual:
 The email is copied to the Sent folder of the account, but it is marked as not read.
Adding qawanted for branch checks.
Keywords: qawanted
Alexandre,
   What device and build were you using? Can you post this info for us?

----------------------------------------------------------

Tested with Shallow Flash on 319mb using Engineering builds

I've tested with the Flame device on multiple builds both Engineering and Nightly but all emails show up as READ in the SENT folder.

This bug does NOT repro on Flame kk build: Flame 2.2 KK, Flame 2.1 KK, Flame 2.0 KK

Actual Result: Sent emails are showing up correctly in the sent folder (read).

Repro Rate: 0/4

Environmental Variables:
Device: Flame 2.2 KK
BuildID: 20141112125016
Gaia: 65d593cdd9d88648045a30a63fc329b7bb5d340b
Gecko: 66cdb18f36da
Version: 36.0a1 (2.2) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
-----------------------------------------------------------------
Environmental Variables:
Device: Flame 2.1 KK
BuildID: 20141112232645
Gaia: 569a299ca446f714cd98d5881cc058fd6f6e257b
Gecko: d188e92aa5a6
Version: 34.0 (2.1) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
-----------------------------------------------------------------
Environmental Variables:
Device: Flame 2.0 KK
BuildID: 20141112171043
Gaia: ab83632c92f9fc571b11d8468b6901cc4ed905c0
Gecko: e21bf45e6c44
Version: 32.0 (2.0) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

-----------------------------------------------------------------
-----------------------------------------------------------------

Nightly build

Environmental Variables:
Device: Flame 2.2 Nightly
BuildID: 20141113040205
Gaia: be8b0151d2f9a4c41fc63952128e0b723cd1161d
Gecko: ab137ddd3746
Version: 36.0a1 (2.2) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(lissyx+mozillians)
QA Contact: croesch
Leaving QAWanted tag and holding off on flag flipping until we get more info.
Flags: needinfo?(jmitchell)
(In reply to Cody Roesch [:croesch] from comment #2)
> Alexandre,
>    What device and build were you using? Can you post this info for us?

As I documented in the bug, I'm getting this on several devices: Nexus S, Xperia ZR, Flame. But I do use the first two for dogfooding, so I spot this much more often on those.
Flags: needinfo?(lissyx+mozillians)
Flags: needinfo?(jmitchell)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Keywords: qawanted
QA Contact: croesch
This is probably fallout from the switch to the email.js libs related to the IMAP APPEND command.  Note that we do *not* use IMAP APPEND on gmail servers (or for ActiveSync or for POP3, sorta-obviously) so we would not expect any problems to reproduce in those cases.

I'm going to speculatively take this and likely fold it into my current email.js upgrade/fix omnibus patch.  I'll unassign and what not if I don't.
Assignee: nobody → bugmail
Status: NEW → ASSIGNED
Depends on: 1097421
(In reply to Andrew Sutherland [:asuth] from comment #5)
> This is probably fallout from the switch to the email.js libs related to the
> IMAP APPEND command.  Note that we do *not* use IMAP APPEND on gmail servers
> (or for ActiveSync or for POP3, sorta-obviously) so we would not expect any
> problems to reproduce in those cases.

I'm not using Gmail, so that would be consistent. One of the account is my mozilla.com, the other one is my beloved Courier-IMAP :)
The problem is that pre-email.js "imap.js" was prepending a backslash on the flags we passed in.  But email.js does not do this (which is reasonable(, so we try and flag the message as 'Seen' rather than '\\Seen' (which is wrong).  I will fix and add test coverage.
Fixed as part of bug 1097421's omnibus patch. Many servers were experiencing more than one bug, and we had experienced some upstream drift, and especially for uplift tracking, it made sense to land these together.  See the gaia-email-libs-and-more pull request's specific commits for the specific fixes and tests.  I am planning to request v2.1 uplift shortly after performing v2.1 testing.
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
blocking-b2g: 2.2? → ---
Batching marking v2.1 fixed since the uplift of bug 1097421 occurred on Dec 9th, thereby fixing all dependent bugs of bug 1097421 on v2.1.  Uplift commit comment is https://bugzilla.mozilla.org/show_bug.cgi?id=1097421#c6
Hi Alexandre,
This issue has been verified successfully on Flame2.1&2.2
Verify video:"0325.mp4".

Flame 2.1:
Gaia-Rev        73be51f998031f06db0cd660c0e388fa621c9f4c
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/05dd053f1d90
Build-ID        20150103001211
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150103.034952
FW-Date         Sat Jan  3 03:50:03 EST 2015
Bootloader      L1TC000118D0

Flame 2.2:
Gaia-Rev        698e6e8a098cc060b26cd6f25171633c4c7e739d
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/57e4e9c33bef
Build-ID        20150103010205
Version         37.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150103.045144
FW-Date         Sat Jan  3 04:51:56 EST 2015
Bootloader      L1TC000118D0
Flags: needinfo?(lissyx+mozillians)
I don't know why the needinfo? :(
Flags: needinfo?(lissyx+mozillians)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.