Panel UI separator icon is wrong for Australis in dev edition 35

RESOLVED FIXED in Firefox 35

Status

()

defect
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: johan.charlez, Assigned: bgrins)

Tracking

unspecified
Firefox 35
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox35 fixed, firefox36 unaffected)

Details

(Whiteboard: [devedition-polish])

Attachments

(2 attachments)

STR: disable the Developer Edition theme

Actual result: separator looks buggy (see screenshot).
Since posting this I've noticed that the menu icon looks scaled down. You can see this clearly in the screenshot posted above.
I think this is the same thing Tim was seeing.  I'll look into it.
I don't see this on m-c with a tip of 0c66a9fd9085 (https://hg.mozilla.org/mozilla-central/rev/0c66a9fd9085) so it must have landed after that.  A likely candidate is Bug 1094509
Weird thing is that I don't see this locally on a build, but I do in the devedition release.  Makes me thing something didn't get uplifted to aurora.
Duplicate of this bug: 1096426
Summary: Firefox Developer Edition Theme not fully disabled. → Panel UI separator icon is wrong for Australis in dev edition 35
Please take comment #1 into account as well
Copying over panelUIOverlay.inc.css from fx-team to aurora doesn't fix it.  Still trying to track it down
Whiteboard: [devedition-polish]
I'm not sure why, but switching 'transparent' to 'rgba(255, 255, 255, 0)' in this gradient fixes it:

http://dxr.mozilla.org/mozilla-central/source/browser/themes/shared/customizableui/panelUIOverlay.inc.css#24-26
I wonder if it's somehow interacting with not having this changeset on aurora: https://hg.mozilla.org/mozilla-central/rev/3adeab7e472d.
So, starting/ending at 'transparent' instead of 'hsla(0,0%,100%,0)' in the gradients for the panel ui button is causing issues on aurora.  I'm guessing that if we uplifted all of https://hg.mozilla.org/mozilla-central/raw-rev/3adeab7e472d it would solve this problem also, but this is a much simpler fix.
Assignee: nobody → bgrinstead
Status: NEW → ASSIGNED
Attachment #8520179 - Flags: review?(dao)
(In reply to Johan C from comment #6)
> Please take comment #1 into account as well

I'm also seeing a smaller panel button in osx/windows 7 (but not on nightly).  Maybe an icon change that wasn't uplifted?  I'll see if I can track that down.
(In reply to Brian Grinstead [:bgrins] from comment #11)
> (In reply to Johan C from comment #6)
> > Please take comment #1 into account as well
> 
> I'm also seeing a smaller panel button in osx/windows 7 (but not on
> nightly).  Maybe an icon change that wasn't uplifted?  I'll see if I can
> track that down.

It looks squashed, if you compare the icons in the screenshot you can see that the icon is wider on the beta channel.
(In reply to Brian Grinstead [:bgrins] from comment #11)
> (In reply to Johan C from comment #6)
> > Please take comment #1 into account as well
> 
> I'm also seeing a smaller panel button in osx/windows 7 (but not on
> nightly).  Maybe an icon change that wasn't uplifted?  I'll see if I can
> track that down.

This appears to be a regression from 1080406, where there is a call to PanelUI.menuButton.classList.add("badged-button").  It's not clear to me why this is a problem only on DevEdition.  Matteo, any ideas why the panel ui button is smaller in the DevEdition release?
ni? for comment 13
Flags: needinfo?(zer0)
Attachment #8520179 - Flags: review?(dao) → review+
Comment on attachment 8520179 [details] [diff] [review]
aurora-panel-separator-fix.patch

Just to be clear, this patch shouldn't land on mozilla-central.
Comment on attachment 8520179 [details] [diff] [review]
aurora-panel-separator-fix.patch

Approval Request Comment
[Feature/regressing bug #]: 1053434
[User impact if declined]: The separator for the panel button in australis is wrong
[Describe test coverage new/current, TBPL]: style change
[Risks and why]: Just changing 'transparent' to 'hsla(0,0%,100%,0)' in a css property
[String/UUID change made/needed]:
Attachment #8520179 - Flags: approval-mozilla-aurora?
Moved needinfo to 1097062, since it is a different problem
Flags: needinfo?(zer0)
Attachment #8520179 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Note: attachment 8520179 [details] [diff] [review] is meant only for aurora uplift, not for landing on m-c
https://hg.mozilla.org/releases/mozilla-aurora/rev/e35ec2feadde
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 35
You need to log in before you can comment on or make changes to this bug.