Closed Bug 1096591 Opened 7 years ago Closed 4 years ago

Hang and reboot of Android system with this video

Categories

(Firefox for Android Graveyard :: Audio/Video, defect)

defect
Not set
critical

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: martijn.martijn, Unassigned)

References

()

Details

(Keywords: crash, hang)

Using current trunk build on Nexus 5, I get a hang of the system and then a reboot when visiting http://people.mozilla.org/~mwargers/tests/videos/lime10s_red10s.mp4
Same device same build, I don't get any hang or crash. The video player reports a time-code of :20, however it plays and stops instantly for me.
(In reply to Aaron Train [:aaronmt] from comment #1)
> Same device same build, I don't get any hang or crash. The video player
> reports a time-code of :20, however it plays and stops instantly for me.

Same. I think this video has really like 4 frames, so maybe we have a problem with this super long frame time.
OK, pretty sure I know what's going on here. We queue the 4 frames as in put, and then the MP4Reader calls Drain() because it's all done. We don't implement that properly, since we treat it as a Flush() and throw away all the pending output frames.
I filed bug 1100116 on it, because it's also crashing on FirefoxOS in the browser.
This specific video plays fine for me. But i have the same issue randomly with other mp4 videos that would totally crash my phone. This only happens when using built-in video player.

This is in Marshmallow on Nexus 5X. Marshmallow on Nexus 5 didn't have this problem.
I have this problem with for me random mp4 videos with Android 6.0 in nexus 5 hammerhead
Cannot reproduce on Nexus 5/Android 4.4 with 57 nightly.

The problem described in comment 3 no longer exists in recent releases (all decoded frames will be returned for Drain()). Close this as fixed for now.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Resolution: FIXED → WORKSFORME
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.