[Messages] Selecting call icon in Messages opens Dialer app without placing the call

RESOLVED DUPLICATE of bug 1032273

Status

Firefox OS
Gaia::SMS
RESOLVED DUPLICATE of bug 1032273
4 years ago
4 years ago

People

(Reporter: AdamA, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.1 affected, b2g-v2.2 affected)

Details

(Whiteboard: [2.2-Daily-Testing], URL)

(Reporter)

Description

4 years ago
Description:
In the messages app when the user chooses to call someone from a messages thread the dialer app will open with the number entered but the call is not placed.


Repro Steps:
1) Update a Flame to 20141110040206
2) Open messages app
3) Send an SMS to any number
4) In the message thread press the call button in the header
5) Observe dialer app open without call being placed

Actual:
The dialer opens with the number input but call is not placed

Expected:
it is expected that a call is placed after pressing button

Environmental Variables:
Device: Flame 2.2 (319mb)(Shallow Flash)
Build ID: 20141110040206
Gaia: 5f8206bab97cdd7b547cc2c8953cadb2a80a7e11
Gecko: d380166816dd
Version: 36.0a1 (2.2)
Firmware Version: v188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Notes:
If user chooses to make a call in the Contacts app the call is placed right away.

Repro frequency: 5/5
See attached: video clip(http://youtu.be/i3T1SBnf3V0), logcat.
(Reporter)

Comment 1

4 years ago
this issue occurs in 2.1 Flame and yesterdays 2.2 Flame.

Environmental Variables:
Device: Flame 2.2
Build ID: 20141107073659
Gaia: 779f05fead3d009f6e7fe713ad0fea16b6f2fb31
Gecko: b62ccf3228ba
Version: 36.0a1 (2.2)
Firmware Version: v188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Device: Flame 2.1
Build ID: 20141110001201
Gaia: 0ec1925fc37b7c71d129ae44e42516a0cfb013c4
Gecko: 97487a2d1ee6
Version: 34.0 (2.1)
Firmware Version: v188
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Result:
Call is not placed automatically after choosing to make a call in messages app.

Notes: In 2.1 there is no call button in the header of the messages app. But selecting the number from the header brings up a list with a call option.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Whiteboard: [2.2-Daily-Testing]
Yep, we have bug 1032273 for it with some discussion inside.

Thanks!
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1032273
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)
You need to log in before you can comment on or make changes to this bug.