Firefox does not automatically use specified application

RESOLVED DUPLICATE of bug 285976

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 285976
3 years ago
3 years ago

People

(Reporter: Humphrey P van Polanen Petel, Unassigned)

Tracking

33 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:33.0) Gecko/20100101 Firefox/33.0
Build ID: 20141105223254

Steps to reproduce:

click on a link to a document


Actual results:

1 - a panel appeared asking me what firefox should do
2 - I selected the appropriate program
3 - I ticked the box <Do this automatically for files like this from now on>
4 - next time firefox asked me again


Expected results:

firefox should have automatically opened the document
>4 - next time firefox asked me again
This happens only if the content-type is guessed or if the server sends a content-disposition:attachment header.
Can you please provide a link to a file where you get this behavior ?
Flags: needinfo?(hpvpp)
(Reporter)

Comment 2

3 years ago
It has been happening for a long time (and I was in a foul mood so I decided to file a bug).
I don't have a URL, but the latest occurrence was when I clicked on the attachment-indicator in Thunderbird.
Flags: needinfo?(hpvpp)
You get this behavior if a page sent a content-disposition:attachment header along with the file.
That header always forces a save as dialog regardless if you have a saved decision for the given file type.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 285976
You need to log in before you can comment on or make changes to this bug.