Closed Bug 1096723 Opened 5 years ago Closed 5 years ago

video.onloadedmetadata fires before video.videoWidth has been filled in

Categories

(Core :: WebRTC: Audio/Video, defect)

38 Branch
All
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 926753

People

(Reporter: jib, Unassigned)

References

()

Details

STR:
1. Open URL and hit [Start].

Actual result (OSX):
    width = 0, height = 0
    width = 0, height = 0

Expected result (OSX):
    width = 640, height = 480
    width = 1280, height = 720

Workaround:
- Uncomment line 15 in the jsfiddle:

  11: .then(stream => {
  12:   video.mozSrcObject = stream;
  13:   return new Promise(resolve => video.onloadedmetadata = e => resolve());
  14: })
  15: //.then(() => waituntil(() => video.videoWidth > 0))
Bug 879717 fixes this.
Blocks: 879717
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 926753
Version: 32 Branch → 38 Branch
You need to log in before you can comment on or make changes to this bug.