[Gallery] Blank screen appears when opening Gallery when USB is connected

VERIFIED FIXED in 2.1 S9 (21Nov)

Status

defect
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: sarsenyev, Assigned: justindarc)

Tracking

unspecified
2.1 S9 (21Nov)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified)

Details

(Whiteboard: [2.1-exploratory-3], URL)

Attachments

(3 attachments)

(Reporter)

Description

5 years ago
Posted file logcat1111
Description:
When opening "Gallery" with USB connected, a blank screen opens

Prerequisites:
Connect the device with USB cable
   
Repro Steps:
1) Update a Flame device to BuildID: 20141111040202
2) Go to "Settings" and toggle on USB 
3) Open "Gallery" 
4) Observe the screen
  
Actual:
Blank screen is displayed
  
Expected: 
Warning message pops up, that the Gallery is not available when USB is connected
  
Device: Flame 2.2 Master
BuildID: 20141111040202
Gaia: 6af3a8a833eb8bb651e8b188cb3f3c3a43bb4184
Gecko: 76b85b90a8cb
Version: 36.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

  
Repro frequency: 90 4/5
See attached: logcat
(Reporter)

Updated

5 years ago
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
(Reporter)

Updated

5 years ago
(Reporter)

Comment 1

5 years ago
YouTube link is attached
Whiteboard: [2.1-exploratory-3]
[Blocking Requested - why for this release]:

The user should be able to see a prompt informing them that they cant see gallery because their device has usb storage enabled. Nominating to block 2.2
blocking-b2g: --- → 2.2?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(dharris)

Comment 3

5 years ago
Blocking Reason: Broken function/regression
blocking-b2g: 2.2? → 2.2+
Justin: see the logcat. There is a reference error on pendingPick, so I think we broke this with the refactoring. Want to take it?
Flags: needinfo?(jdarcangelo)
(Assignee)

Updated

5 years ago
Assignee: nobody → jdarcangelo
Flags: needinfo?(jdarcangelo)
(Assignee)

Comment 5

5 years ago
Attachment #8523038 - Flags: review?(dflanagan)
Comment on attachment 8523038 [details] [review]
pull-request (master)

r- because I'd rather have the performance benefit of the lazy loading than the possible modularity benefit of Pick.isPicking(). And, as I argue on github, I conceptuatlize the existing 'picking' variable as part of the top-level application state, not part of the state of the pick module.

So I'd prefer a much simpler patch that just changes pendingPick to picking.

If you have other concerns (like you think the lazy loading is going to cause problems) let's discuss and you can try to convince me.  But the benefit of not having to load the pick module into the app for regular non-pick invocations is a concrete performance win from this refactoring that seems worth keeping.
Attachment #8523038 - Flags: review?(dflanagan) → review-
(Assignee)

Comment 7

5 years ago
Revised PR to address your concerns with my first one.
Attachment #8523119 - Flags: review?(dflanagan)
Comment on attachment 8523119 [details] [review]
alternate pull-request (master)

I love 2-line patches! \o/
Attachment #8523119 - Flags: review?(dflanagan) → review+
(Assignee)

Comment 9

5 years ago
Landed on master:

https://github.com/mozilla-b2g/gaia/commit/6a9f8347011ee1652677bd71b6624baf4389f77e
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Updated

5 years ago
Target Milestone: --- → 2.1 S9 (21Nov)
Issue verified fixed on Flame 2.2 following STR in comment 0

Memory card in use message appears on screen when accessing Gallery while USB storage is enabled

Device: Flame 2.2 (319mb)(Kitkat Base)(Shallow Flash)
Build ID: 20141121040204
Gaia: 25388c6bce932657ebf93adedf31881bfaf88c15
Gecko: 3366c0fcf9c2
Version: 36.0a1 (2.2)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.