Can't log in to Synology NAS after upgrade from Fx ESR 24 to 31

RESOLVED INVALID

Status

()

Firefox
Untriaged
RESOLVED INVALID
3 years ago
3 years ago

People

(Reporter: JoeG, Unassigned)

Tracking

31 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20141016 Firefox/24.0
Build ID: 20141016000501

Steps to reproduce:

1. Actually, the problem is on two machines.

On one I updated from ESR 24 to ESR 31 and on another from ESR 24 to Nightly 36. ESR 24 was 32 bit; the updates are 64 bit.

2. I tried to log into my Synology 109+ with the latest DSM (4.2.3252)

3. On both machines I got the error "You have logged in and out of DSM using another web browser, or DiskStation has been restarted. Please log in to DSM again."


Actual results:

I tried to log in again on both machines (several times and even restarted my computer and the NAS). The error message came up every time.

Just as a test, I tried to log in with IE 11, which I had NEVER used to log in to the Synology. It worked fine. 


Expected results:

I should have been able to log in with Fx.
(Reporter)

Updated

3 years ago
Version: 24 Branch → 31 Branch
(Reporter)

Comment 1

3 years ago
Whops, the ESR 31 was also 32 bit. Sorry.
I have no issue accessing the my ds214se running DSM5.1 with Firefox32 and Firefox33 and I can't remember to have an issue with Firefox31
Do you get the error also with an additional test profile ?
http://support.mozilla.org/kb/Managing%20profiles
Flags: needinfo?(jgreenman)
(Reporter)

Comment 3

3 years ago
Good tip.

Starting Fx in Safe Mode I get the same problem.

Starting with a new profile it works as expected. 

How can I test further, please? Thanks.
Flags: needinfo?(jgreenman)
(Reporter)

Comment 4

3 years ago
PLEASE excuse me for wasting your time. 

I just discovered that I needed to allow cookies on the page. 

Now it works as expected.
yes, the error message from the nas is telling you that it can not find the session cookie.
i have expected that you have some kind of privacy addon installed that blocks the cookie (safemode) or a corrupt cookie file (new profile).

anyway, marking invalid
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.