Closed Bug 1097362 Opened 5 years ago Closed 5 years ago

[e10s] Nightly hangs when reloading imgur.com

Categories

(Core :: Plug-ins, defect, major)

defect
Not set
major

Tracking

()

RESOLVED WORKSFORME
Tracking Status
e10s + ---

People

(Reporter: stephend, Unassigned)

References

()

Details

Build ID:  Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:36.0) Gecko/20100101 Firefox/36.0

Built from https://hg.mozilla.org/mozilla-central/rev/cbe6afcae26c

Shockwave Flash

    File: NPSWF64_15_0_0_223.dll
    Path: C:\Windows\system32\Macromed\Flash\NPSWF64_15_0_0_223.dll
    Version: 15.0.0.223
    State: Enabled
    Shockwave Flash 15.0 r0

STR:

1. Using nightly (on at least 64-bit Windows 7) with e10s enabled, load http://imgur.com/
2. Now reload while holding SHIFT

Actual Results:

Nightly hangs
Related to bug 1093782 and/or bug 1093693?
Flags: needinfo?(jmathies)
tracking-e10s: --- → +
Flags: needinfo?(jmathies)
(In reply to Georg Fritzsche [away Nov 15 - Nov 30] [:gfritzsche] from comment #2)
> Related to bug 1093782 and/or bug 1093693?

Very likely, as the "upload images" button is in fact Flash-based; note, though, that yesterday + today with nightly, I'm as of yet unable to repro :-(
On a Surface Pro with Win8.1 and same flash version as in comment #0 I am not able to reproduce this problem as described. No hang.

However, after a few reloads and after letting the page load completely, I get the "Tab crashed" page and clicking on "try again" tries to reload the page but I end up in the same "tab crashed" page after few seconds.
(In reply to juan becerra [:juanb] from comment #4)
> On a Surface Pro with Win8.1 and same flash version as in comment #0 I am
> not able to reproduce this problem as described. No hang.
> 
> However, after a few reloads and after letting the page load completely, I
> get the "Tab crashed" page and clicking on "try again" tries to reload the
> page but I end up in the same "tab crashed" page after few seconds.

bug 1099274

If anyone can successfully reproduce on Windows in the latest nightly, please post back / reopen. Note this might still reproduce on mac since plugin work there hasn't landed.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.