Send Unsent Messages: Message remains in Unsent folder

VERIFIED FIXED

Status

P3
major
VERIFIED FIXED
19 years ago
10 years ago

People

(Reporter: nbaca, Assigned: rhp)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
1999073011M9/Necko: Win32/NT4

Overview Description: After selecting to Send a message later it goes to the
Unsent folder but it never sends the message even after selecting File/Send
Unsent Messages.

Steps to Reproduce:
1. Launch Mail
2. Select New Message button so the compose window appears.
3. Create a message by addressing it, typing in the subject and the message
body.
4. Select File/Send Later. The compose window may not close by itself, just
select the X box.
5. Go to the Unsent Message folder to verify the messages is there.
6. Select File/Send Unsent Messages.

Actual Results: The message remains in the Unsent Messages folder and never gets
sent.

Expected Results: It should have disappeared from the Unsent Messages folder and
then viewed in the recipients mail application.

Additional Builds and Platforms Tested On:
- Using a single POP, non-Necko build works.

Additional Information:
- Tried closing the application, restarting and sending again but it still
remains in the Unsent Messages folder.


Will try Linux and Mac.

Updated

19 years ago
Assignee: gagan → mscott

Updated

19 years ago
Severity: normal → major
Component: Necko → Back End

Updated

19 years ago
Assignee: mscott → rhp

Comment 1

19 years ago
re-assigning to rhp who handles the unsent folder stuff.
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 2

19 years ago
I just fixed this. Somehow the pref to turn off deletion got changed to
something that would have always been true. So if you want to turn off deletion
of "Sent Unsent Messages" from your Drafts folder, set the pref:

                    "mail.really_delete_draft"

to false. It defaults to true.

- rhp
(Reporter)

Comment 3

19 years ago
The problem is that the messages remain in the Unsent Messages folder and not
the Draft folder. Would your statement still apply?
(Assignee)

Comment 4

19 years ago
sorry...mistyped...yes.
(Reporter)

Updated

19 years ago
Status: RESOLVED → REOPENED
(Reporter)

Comment 5

19 years ago
Build 1999080408M9: Win32/NT4
Reopening because it doesn't appear fixed.

I created a new message, selected File/Send Later which saved the message to the
"Unsent Messages" folder. Then selected File/Send Unsent Messages but nothing
happens.

Linux build 8/02am: Messages remain in Unsent Messages folder. Couldn't try 8/04
build because the Sidebar is blank.

Mac 8.5.1 8/04 build. Messages remain in Unsent Messages folder. Not able to
create new messages due to Compose problems.

Updated

19 years ago
Resolution: FIXED → ---
(Assignee)

Updated

19 years ago
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 6

19 years ago
I ended up fixing this today. Yes, there was a problem with finding the correct
folder for appropriate copy/delete operations.

Let me know if I'm off, but I think I got it this time :-)

- rhp

Updated

19 years ago
QA Contact: lchiang → nbaca

Comment 7

19 years ago
Ninoschka - I'm setting you as QA contact on this one since you've been working
on this :-)
(Reporter)

Comment 8

19 years ago
Build 1999080608M9: Win32/NT4

Fixed for NT4. Using a single POP account, messages in the "Unsent Messages"
folder are sent.

Linux: Unable to test with todays build since folders are not appearing.
Mac: Unable to test with todays build since unable to send.
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 9

19 years ago
1999081608M9: Win32/Win98, Linux/Redhat 6.0, Mac 8.5.1
Verified Fixed. All messages in the Unsent Messages folder were sent.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.