Closed Bug 1097437 Opened 5 years ago Closed 5 years ago

Corners of Quartz StrokeRects are slightly off color

Categories

(Core :: Graphics, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla36
Tracking Status
firefox34 --- fixed
firefox35 --- fixed
firefox36 --- fixed

People

(Reporter: roc, Assigned: roc)

References

Details

Attachments

(1 file, 2 obsolete files)

Drawing a simple <div style="border:1px solid black"> on a white background on Mac gives us corner pixels that are rgb(1,1,1) instead of rgb(0,0,0).
Attachment #8521100 - Flags: review?(jmuizelaar) → review+
try showed a few issues:
http://hg.mozilla.org/mozilla-central/raw-file/tip/layout/tools/reftest/reftest-analyzer.xhtml#logurl=http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/rocallahan@mozilla.com-00e6553ea192/try-macosx64-debug/try_snowleopard-debug_test-reftest-bm106-tests1-macosx-build3407.txt.gz&only_show_unexpected=1

* a couple of UNEXPECTED-PASSes ... so this was in fact already biting us.
* we shouldn't disable antialiasing when the pattern is not a solid color (since that will affect resampling of gradients/surfaces)
* we should generalize the workaround slightly so that it handles rotations by multiples of 90 degrees
Attachment #8521198 - Flags: review?(jmuizelaar) → review+
https://hg.mozilla.org/mozilla-central/rev/2999f246a4e2
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla36
Comment on attachment 8521198 [details] [diff] [review]
fix v3

We need to uplift this patch to Beta and Aurora in support of bug 1092842. Roc tells me that this is low risk. Certainly seems worth taking two low risk fixes as opposed to shipping a visible YouTube regression. Beta+ Aurora+
Attachment #8521198 - Flags: approval-mozilla-beta+
Attachment #8521198 - Flags: approval-mozilla-aurora+
Looks like those unexpected passes from comment 2 just showed up on aurora and beta following that landing.
I just landed the **reftest manifest changes only** from bug 1096181 on aurora and beta, because those changes actually belonged in either this bug or bug 1092842, which were just landed in both places:

https://hg.mozilla.org/releases/mozilla-aurora/rev/187e9fa68b67
https://hg.mozilla.org/releases/mozilla-beta/rev/c486cd17bebb
You need to log in before you can comment on or make changes to this bug.