Single Global switch to disable GPS for apps in background

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
4 years ago
10 months ago

People

(Reporter: timdream, Unassigned)

Tracking

unspecified

Firefox Tracking Flags

(tracking-b2g:+)

Details

(Whiteboard: [ft:Peripherals])

Attachments

(1 attachment)

This is Gaia part of bug 1093618, a proposed 2.2 feature. Please read the user story there.

At the time of filing this bug I am not sure we are going for one switch that disables all geolocation usage for background apps, or for individual apps, or even no switches (and hook to existing "power saving" switch). No effort estimation can be given without this information from product/ux.
Flags: needinfo?(firefoxos-ux-bugzilla)
Flags: needinfo?(bhuang)

Updated

4 years ago
Duplicate of this bug: 1098461
For 2.2 we'll use a single global switch.  Moving the UX ni to Jenny when spec becomes available.
Flags: needinfo?(jelee)
Flags: needinfo?(firefoxos-ux-bugzilla)
Flags: needinfo?(bhuang)
feature-b2g: 2.2? → 2.2+

Comment 3

4 years ago
Created attachment 8525034 [details]
[2.2 Settings] Geolocation v1.0.pdf

See attached for spec v1.0, thanks!
Flags: needinfo?(jelee)

Updated

4 years ago
Whiteboard: [ft:Peripherals]
tracking-b2g: --- → +

Updated

4 years ago
Summary: Switch(es?) for disable GPS for apps in background → Single Global switch to disable GPS for apps in background
blocking-b2g: --- → backlog

Comment 4

4 years ago
Not in scope of v2.2
feature-b2g: 2.2+ → ---
blocking-b2g: backlog → ---

Comment 5

10 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.