All users were logged out of Bugzilla on October 13th, 2018

[email] Implicit z-index could lead to covering dialogs and value selectors

RESOLVED FIXED in Firefox OS v2.2

Status

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: yulan.zhu, Assigned: jrburke)

Tracking

unspecified
2.1 S9 (21Nov)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.0 affected, b2g-v2.1 affected, b2g-v2.2 verified)

Details

Attachments

(4 attachments)

(Reporter)

Description

4 years ago
Created attachment 8521282 [details]
logcat

[1.Description]:
[Flame][v2.1][Email]There is no response when user empty the content of the new email and tap back button.
Attach logcat:logcat.txt.
Attach video:Video.mp4.
Occurrence time:15:11

[2.Testing Steps]: 
1.Launch Email and sign in Gmail account.
2.New the email and add the video from the Camera.
3.Run Email in the background.
4.Launch Video and delete some videos.
5.Launch Email again.
6.Delete the video in the mail and tap back button.

[3.Expected Result]: 
6.Should go back to the previous page.

[4.Actual Result]: 
6.There is no response.

[5.Reproduction build]: 
Gaia-Rev        7154f9aa0a69af56c8bd89be0c98d9791449527b
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/452db1a0c9a0
Build-ID        20141111001201
Version         34.0

[6.Reproduction Frequency]: 
Twice,2/50
(Reporter)

Comment 1

4 years ago
Created attachment 8521284 [details]
Video
There's not a lot in the log, but what is there is just a whole bunch of these:
11-12 15:11:36.959 I/GeckoDump( 5570): LOG: compose: back: save needed, prompting

This suggests our call to document.body.appendChild is probably working but there is some type of z-index problem OR the 'submit' event it somehow being fired immediately.  (If it was just a painting problem, we would not expect that tapping on the input fields would transfer control.)  Either way it's very confusing.

If anyone is able to reproduce this, using the Firefox DevTools WebIDE to attach to the device and using the DOM inspector to copy and paste the entirety of the HTML DOM so we can inspect the ordering/etc. is probably most useful.  It's also possible that something interesting shows up in the logcat earlier in the process; simply testing/reproducing with the logcat already logging to disk could also be quite useful.
(Assignee)

Comment 3

4 years ago
A community member contacted me in IRC, :sharaf, on Nov 10th, mentioned that they had found an issue where if you open the drawer 10 times, then the z-index for the cards hid any value selector shown after that.

The fix was to set an explicit z-index: 0 on #cardContainer. :sharaf wanted to do the fix, so I suggested that they should file a bug and we talked about the fix. I lost track since then, and since there is no bug for it yet, let's use this one and I will do a quick pull request with the fix.
Assignee: nobody → jrburke
Status: NEW → ASSIGNED
Target Milestone: --- → 2.1 S9 (21Nov)
(Assignee)

Comment 4

4 years ago
I believe it was a quirk of steps to reproduce that led to marking this as 2.2 unaffected. The following steps mean I can reproduce reliably on 2.2, and the core issue has been there for a while, perhaps even since 1.1.

Also renaming the title of the bug to make it more generic.

STR:

* Open and close the menu drawer 12 times.
* Then go to compose, type something, press back. Nothing happens.

Also, after opening the drawer 12 times (although 10 should really be enough, I just did 12 to really be sure we were over on the z-index), trying to move messages to other folders leads to the same stuck response.

It is because in all those cases the dialogs are shown, but are placed under the current z-index used by the cards.
status-b2g-v2.0: --- → affected
status-b2g-v2.2: unaffected → affected
Summary: [Flame][Email]There is no response when user empty the content of the new email and tap back button. → [email] Implicit z-index could lead to covering dialogs and value selectors
(Assignee)

Comment 5

4 years ago
Created attachment 8524710 [details] [review]
GitHub pull request

Just a CSS change, adding explicit z-index: 0 to the cardContainer.
Attachment #8524710 - Flags: review?(bugmail)
(Assignee)

Comment 6

4 years ago
Comment on attachment 8524710 [details] [review]
GitHub pull request

Received r=asuth in IRC discussion.

Merged in master:
https://github.com/mozilla-b2g/gaia/commit/84568ce3fdd5b4fb5a7e8d85188b97bc5ecc19cb

from pull request:
https://github.com/mozilla-b2g/gaia/pull/26261
Attachment #8524710 - Flags: review?(bugmail)
(Assignee)

Updated

4 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
status-b2g-v2.2: affected → fixed
Resolution: --- → FIXED
This bug has been successfully verified on latest Flame v2.2.
See attachment: verified_v2.2.MP4.
Reproduce rate: 0/5

Flame 2.2 build:
Build ID               20150215002504
Gaia Revision          ea64caf6d4ab03fc4472eca9f41f20d651d55fa9
Gaia Date              2015-02-13 05:27:43
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/62c80c92b39e
Gecko Version          37.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150215.040852
Firmware Date          Sun Feb 15 04:09:03 EST 2015
Bootloader             L1TC000118D0
status-b2g-v2.2: fixed → verified
Created attachment 8564883 [details]
verified_v2.2.MP4
QA Whiteboard: [MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.