app's screenshot in card view is partially broken on b2g v2.2

RESOLVED WORKSFORME

Status

defect
RESOLVED WORKSFORME
5 years ago
4 years ago

People

(Reporter: sotaro, Assigned: sfoster)

Tracking

({regression})

unspecified
2.1 S9 (21Nov)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 affected)

Details

(Whiteboard: [systemsfe])

Attachments

(3 attachments)

(Reporter)

Description

5 years ago
"Bind Search" and "Bing Maps"'s screenshot in card view is partially broken on b2g v2.2. It did not happens on b2g v2.0 and b2g v2.2.

STR
[1] install "Bind Search" and "Bing Maps" from Firefox Marketplace.
[2] start either app.
[3] long press "home button". It makes to move to "card view".

When [3] is done, app's screen shot is shown in card view. The top of screenshot is incorrectly drawn.
(Reporter)

Comment 1

5 years ago
(Reporter)

Comment 2

5 years ago
(Reporter)

Updated

5 years ago
blocking-b2g: --- → 2.2?
(Reporter)

Comment 3

5 years ago
It is not clear yet, which part causes the problem. Since b2g v2.2, card view seems to have a big change. Therefore it seems better that the problem is analyzed by system app at first.
(Reporter)

Updated

5 years ago
Component: Graphics → Gaia::System
Product: Core → Firefox OS
(Reporter)

Comment 4

5 years ago
Changed component to Gaia::System based on comment 3.
(Assignee)

Updated

5 years ago
Whiteboard: [systemsfe]
This issue does not occur on the Flame 2.1

Both Bing Search and Bing Maps show correctly in card view.

Flame 2.1

Device: Flame 2.1 (319mb)(Kitkat Base)(Shallow Flash)
BuildID: 20141112001201
Gaia: 4c159e75a1568afbbf0c83c1235ec56facfbe87d
Gecko: b9849b3c6aaa
Version: 34.0 (2.1)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
(Reporter)

Comment 6

5 years ago
(In reply to Sotaro Ikeda [:sotaro] from comment #0)
> "Bind Search" and "Bing Maps"'s screenshot in card view is partially broken
> on b2g v2.2. It did not happens on b2g v2.0 and b2g v2.2.

Correction:
  It did not happens on b2g v2.0 and b2g v2.1.
QA Contact: jmitchell
blocking-b2g: 2.2? → 2.2+
Central Regression Window:

Last Working:
Device: Flame 2.2
Build ID: 20140916155959
Gaia: e2d70bee03b5380ac327a145e5d694fb2443f018
Gecko: 543f57ab6a44
Gonk: Could not pull gonk.  Did you shallow Flash?
Version: 35.0a1 (2.2)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

First Broken:
Device: Flame 2.2
Build ID: 20140916162300
Gaia: 50666fa8bbbf3d346faff24f92ad8140a44a49d0
Gecko: 49ef7b18963d
Gonk: Could not pull gonk.  Did you shallow Flash?
Version: 35.0a1 (2.2)
Firmware Version: v188-1
User Agent: Mozilla/5.0

Gaia/Gecko Swap
Last Working Gaia First Broken Gecko: Issue does NOT reproduce
Gaia: e2d70bee03b5380ac327a145e5d694fb2443f018
Gecko: 49ef7b18963d
First Broken Gaia Last Working Gecko: Issue DOES reproduce
Gaia: 50666fa8bbbf3d346faff24f92ad8140a44a49d0
Gecko: 543f57ab6a44

Gaia pushlog: https://github.com/mozilla-b2g/gaia/compare/e2d70bee03b5380ac327a145e5d694fb2443f018...50666fa8bbbf3d346faff24f92ad8140a44a49d0

--------------------------------------------------------------

B2G Regression Window:

Last Working:
Device: Flame 2.2
Build ID: 20140916104558
Gaia: 506da17d0f8dce5d1731b5fc48d5b64c52f55135
Gecko: ffd263ab3bc8
Gonk: Could not pull gonk.  Did you shallow Flash?
Version: 35.0a1 (2.2)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

First Broken:
Device: Flame 2.2
Build ID: 20140916111756
Gaia: 1503e1f9f7846a3813c057ce95c35ac22031027f
Gecko: 1f7b6f450ef3
Gonk: Could not pull gonk.  Did you shallow Flash?
Version: 35.0a1 (2.2)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0


Gaia/Gecko Swap
Last Working Gaia First Broken Gecko: Issue does NOT reproduce
Gaia: 506da17d0f8dce5d1731b5fc48d5b64c52f55135
Gecko: 1f7b6f450ef3
First Broken Gaia Last Working Gecko: Issue DOES reproduce
Gaia: 1503e1f9f7846a3813c057ce95c35ac22031027f
Gecko: ffd263ab3bc8

Gaia pushlog: https://github.com/mozilla-b2g/gaia/compare/506da17d0f8dce5d1731b5fc48d5b64c52f55135...1503e1f9f7846a3813c057ce95c35ac22031027f


Possibly broken by bug 1044125 - can you take a look Aus?
QA Whiteboard: [QAnalyst-Triage+]
Flags: needinfo?(aus)
QA Contact: jmitchell
I would love to help out with this one but I'm a little bit swamped right now with a slew of downloads related issues on various branches and devices. sam, could you have a look? I'm a little dubious of the status bar icon changes... it's also possible that we're mistaking these windows as browser windows and are attempting to overlay both browser chrome and browser content screenshots.
Flags: needinfo?(aus) → needinfo?(sfoster)
(Assignee)

Comment 9

5 years ago
I'll take a look and see if I can spot what's going on
Assignee: nobody → sfoster
Flags: needinfo?(sfoster)
Target Milestone: --- → 2.1 S9 (21Nov)
(Assignee)

Comment 10

4 years ago
I cant reproduce this with recent 2.2/master. I do however see the symptoms described in bug 1107139, I hope we didn't swap one bug for another.
(Assignee)

Comment 11

4 years ago
Resolving as worksforme. I'll make it block 1107139 though so we can re-test and confirm fixing one doesn't break the other
Blocks: 1107139
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.