If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Sync encountered an error while syncing : unknonw error

RESOLVED DUPLICATE of bug 1034979

Status

()

Firefox
Sync
RESOLVED DUPLICATE of bug 1034979
3 years ago
3 years ago

People

(Reporter: magsout, Unassigned)

Tracking

35 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
Since I installed the Developer version, I can not sync with sync. I uninstall all versions of firefox, clean my profile. The Nightly and Stable version  sync without errors.

Here about:sync-log  :

https://gist.github.com/magsout/85e11b455abbc91658c8

Comment 1

3 years ago
Yeeeeeeeeeeeeep. Here too. Sad kud is sad.
The "Weave is disabled" error is likely caused by a previous failure. Can you attach/link to all recent logs from about:sync-log?
(Reporter)

Comment 3

3 years ago
Yes here https://gist.github.com/magsout/d5d04ebf8d15042aef3a
(Reporter)

Comment 4

3 years ago
I  used AppCleaner to removed any version of Firefox. I installed the developer version of Firefox and I still can not use sync 

Here error log : https://gist.github.com/magsout/9d253eee67af67308443

If I try with stable or nightly I have always an error
> Crypto check failed: [Exception... "PK11_GenrateRandom failed" nsresult: "0x80004005 (NS_ERROR_FAILURE)" location: "JS frame :: resource://gre/modules/services-crypto/WeaveCrypto.js :: WeaveCrypto.prototype.generateRandomBytes :: line 550" data: no]
> 1416906787953	Sync.Service INFO Could not load the Weave crypto component. Disabling Weave, since it will not work correctly. 

This error appears to be the same as Bug 1034979.
From the above-linked bug, I guess this *should* be fixed in at least Nightly, but you report that it still gives you an error.  Guillaume, can you confirm whether the error log contains the same "PK11_GenrateRandom failed" message when run on latest nightly?
(Reporter)

Comment 7

3 years ago
Yeah thanks Ryan, I just installed the latest nightly and actually I can again synchronize without errors, Nice.
OK, that's good news, thanks for reporting back.  I'll go ahead and resolve this as a dupe of the other bug.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1034979
You need to log in before you can comment on or make changes to this bug.