[Contacts] [Regression] Facebook contact photo should not be removed and user should be able to add a local photo

VERIFIED FIXED in 2.1 S9 (21Nov)

Status

defect
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: zikui.yang, Assigned: jmcf)

Tracking

({regression})

unspecified
2.1 S9 (21Nov)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.0 unaffected, b2g-v2.1 affected, b2g-v2.2 verified)

Details

Attachments

(5 attachments)

Reporter

Description

5 years ago
Posted file logcat.txt
[1.Description]:
[Flame][v2.1&2.2][Contacts]Can't delete the headportrait of facebook contact.
PS:The facebook contact name can be edit,but can't be save changement.
Picture:1.png and 2.png
log:logcat.txt
Happen time:4:53

[2.Testing Steps]: 
Precondition:Impormt some contatcs from facebook
1.Launch Contacts
2.Tap a facebook contacts with headportrait
3.Tap edit->tap headportrait to edit->tap delete
>>You can see the headportrait has been deleted
4.Tap Update to save the changes

[3.Expected Result]: 
4.The contact headportrait should not be shown.

[4.Actual Result]: 
4.The contact headportrait is still shown.

[5.Reproduction build]: 
FLame2.1 build:
Gaia-Rev        4c159e75a1568afbbf0c83c1235ec56facfbe87d
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/b9849b3c6aaa
Build-ID        20141112001201
Version         34.0

FLame2.2  build:
Gaia-Rev        5ae28ff11b982e2bd7d1aa097cda131536952bdc
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/688f821edcd4
Build-ID        20141112040208
Version         36.0a1

[6.Reproduction Frequency]: 
Always Recurrence,5/5
Reporter

Comment 1

5 years ago
Posted image 1.png
Reporter

Comment 2

5 years ago
Posted image 2.png
I'm sure it's by design. But in 2.0 and inferior, we don't show the delete button. So we should continue hiding this button when we have a Facebook contact. An end user might think this is a broken functionality. See video for details.

[Blocking Requested - why for this release]: Regression due to the redesign of the Edit page.
blocking-b2g: --- → 2.1?
Keywords: regression
triage: not a major regression so non-blocking. We want it to be fixed and uplifted so I'm nominating 2.2.
blocking-b2g: 2.1? → 2.2?
Target Milestone: --- → 2.2 S2 (19dec)
Assignee

Updated

5 years ago
Assignee: nobody → jmcf
Target Milestone: 2.2 S2 (19dec) → 2.1 S9 (21Nov)
Assignee

Updated

5 years ago
Summary: [Flame][Contacts]Can't delete the headportrait of facebook contact. → [Contacts] [Regression] Facebook contact photo should not be removed and could be changed by a local photo
Assignee

Updated

5 years ago
Summary: [Contacts] [Regression] Facebook contact photo should not be removed and could be changed by a local photo → [Contacts] [Regression] Facebook contact photo should not be removed and user should be able to add a local photo
Assignee

Comment 6

5 years ago
Posted file 26258.html
Attachment #8524674 - Flags: review?(francisco)
triage: blocking 2.2.
blocking-b2g: 2.2? → 2.2+
Comment on attachment 8524674 [details]
26258.html

Nice work, I've relaunched some works in gaia-try, but seems an integration test is not passing (related to system).

Could you rebase against master to see if it's fixed?
Attachment #8524674 - Flags: review?(francisco) → review+
Jose could you record a video for the sprint demo?

https://wiki.mozilla.org/Gaia/Contacts/Scrum/2.1S9#Demos
Status: NEW → ASSIGNED
Assignee

Comment 10

5 years ago
https://github.com/mozilla-b2g/gaia/commit/d695e7cdcd162e779e15594054931c84dec34a95
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
This issue is verified on Flame 2.2.

Result: "Remove photo" option no longer exists with Facebook contacts. The user can successfully change the profile photo with a local photo.

Device: Flame 2.2 (319mb, KK, Shallow Flash)
BuildID: 20141124100136
Gaia: aad40f6d6eb8f626c6a20db55b9f00d2e832f113
Gecko: be4ba3d5ca9a
Version: 36.0a1 (2.2) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
==============================================
Leaving verifyme for 2.1 patch uplift.
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: verifyme
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
The v2.2 has verified, clear 'verifyme' keywords.
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.