impress.js - Font-rendering changes after animation stops

UNCONFIRMED
Unassigned

Status

()

Core
Layout: Text
UNCONFIRMED
3 years ago
3 years ago

People

(Reporter: Elbart, Unassigned)

Tracking

Trunk
x86_64
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

3 years ago
Created attachment 8522178 [details]
impress_text_rendering_before.png

+++ This bug was initially created as a clone of Bug #1098266 +++

Nightly 2014-11-12


Open URL and press right-arrow to go to the next element ("Have you noticed it's in 3D*?")

The text is animating, and for short time after animation stopped, the text is unchanged, and then it changes the way it's rendered.

Especially note the asterisk behind "3D".

Regression-range:
m-c:
Last good revision: 80499f04e875 (2012-09-19)
First bad revision: 1e56d3016820 (2012-09-20)
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=80499f04e875&tochange=1e56d3016820

Maybe
Bug 774169 - Strange zooming behavior has appeared in Bing Maps 
or
Bug 777194 - over invalidation when scrolling 
?
(Reporter)

Comment 1

3 years ago
Created attachment 8522179 [details]
impress_text_rendering_after.png
(Reporter)

Updated

3 years ago
Blocks: 774169, 774194
(Reporter)

Updated

3 years ago
Blocks: 777194
No longer blocks: 774194
(Reporter)

Comment 2

3 years ago
Created attachment 8522275 [details]
impress_font.mp4.mp4

Or visit http://bartaz.github.io/impress.js/#/its-in-3d and press right arrow to go to the overview.
you can see the big chunk of text in the middle switch between two text-renderings.

Changing the size of the window when the overview is shown works, too.

Last good revision: cd4853b0b94a (2012-02-26)
First bad revision: d1b2fd680235 (2012-02-27)
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=cd4853b0b94a&tochange=d1b2fd680235

Maybe
7dcff354aeae	Aryeh Gregor — Bug 724614 - 3D scaling makes text blurry. r=mattw

Attached video created with Nightly 2014-07-20 because of 1098266.
(Reporter)

Updated

3 years ago
Blocks: 724614
Comment hidden (typo)
Oops, marked a wrong bug number, sorry...
Assignee: quanxunzhen → nobody
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---
Target Milestone: mozilla37 → ---
You need to log in before you can comment on or make changes to this bug.