Closed Bug 1098300 Opened 5 years ago Closed 5 years ago

[v2.2] Investigate test_dialer_miss_call_from_known_contact_notification.py intermittent failure

Categories

(Firefox OS Graveyard :: Gaia::UI Tests, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: RobertC, Assigned: viorela)

Details

Attachments

(1 file)

test_dialer_miss_call_from_known_contact_notification.py has been failing on Jenkins intermittently.
http://jenkins1.qa.scl3.mozilla.com/view/UI/job/flame-kk-319.mozilla-central.ui.functional.non-smoke/116/HTML_Report/

From the screenshot and stacktrace it looks like the device enters sleep mode while on the lockscreen and then fails to unlock
The issue cannot be reproduced manually.
Reproduction rate with automation: 1 out of 10

I will investigate this further.
QA Whiteboard: [fxosqa-auto-s4+]
I investigated this issue, and indeed the test is failing because sometimes the device enters sleep mode while on the lockscreen. 

In test_dialer_miss_call_from_known_contact_notification.py, we are waiting for the missed call notification to appear and also to dissapear before unlock. But the device enters sleep mode when the notification is displayed, so it causes the test to fail.

Peter, is expected that the device enter sleep mode before the notification dissapears? If yes, then I will update our test. Thanks!
Flags: needinfo?(pbylenga)
I tried a fix here, and also started an adhoc.
Can you guys take a look? Thanks!
Attachment #8522922 - Flags: review?(pbylenga)
Attachment #8522922 - Flags: review?(florin.strugariu)
Attachment #8522922 - Flags: review?(robert.chira)
Assignee: robert.chira → viorela.ioia
Attachment #8522922 - Flags: review?(robert.chira) → review+
Attachment #8522922 - Flags: review?(florin.strugariu) → review+
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
I believe that's expected.
Flags: needinfo?(pbylenga)
Attachment #8522922 - Flags: review?(pbylenga) → review+
You need to log in before you can comment on or make changes to this bug.