Disabled items in contextual menus shouldn't highlight on mouseover on Mac OS

VERIFIED INVALID

Status

()

Core
XUL
--
trivial
VERIFIED INVALID
17 years ago
10 years ago

People

(Reporter: Andy Lyttle, Assigned: David Hyatt)

Tracking

Trunk
PowerPC
Mac System 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:0.9.5+) Gecko/20011109
BuildID:    2001110908

On Mac OS, disabled items in menus do not highlight when you move the mouse over
them.  In Mozilla, disabled items do highlight in contextual menus.

Reproducible: Always
Steps to Reproduce:
1. Right-click (control-click) on a Web page
2. Move the mouse over a disabled item

Actual Results:  The item highlights

Expected Results:  The item should not highlight

This is a rehash of Bug 59797.

This is Mac-only, since disabled menu items do normally highlight on Win32 and
Linux.

This bug only applies to contextual menus, since normal menus use the system
menubar, and thus the system highlighting behavior.

Bug 59797 mentioned a hack to access menus from the keyboard.  In that
situation, disabled menu items should be skipped, not highlighted.  I've seen
hacks for the Mac OS to allow keyboard access to the menubar, and disabled items
are skipped.

Comment 1

17 years ago
(Let's leave the final point, about keyboard nav of disabled items on Mac as a 
separate issue).

Currently, in the Mac Classic skin, disabled menu items do not highlight.
However, they do highlight in the Modern skin on Mac (and win32 and linux
which also use this same skin).

Turning it off is like so:
http://lxr.mozilla.org/seamonkey/source/themes/classic/global/mac/menu.css#72

but I don't know to what degree we are doing platform tweaks in the Modern 
skin. (This is probably more matter for UE than toolkit, but ...)
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 2

17 years ago
ohhhh, gotcha.  That actually crossed my mind, and I was gonna test it with the
Classic skin and forgot.  Whoops.  It's late, and I'm tired.

As far as I'm aware, Modern is platform-independent, which is why form elements
(buttons and such) are so damned ugly (a striking contrast from the smooth
elegant look of the rest of the skin).  There could be a few platform tweaks,
but I'd think if there were any, they'd at least fix the form buttons.

Comment 3

17 years ago
So is this invalid, then?
(Reporter)

Comment 4

17 years ago
Yep, my bad.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID

Comment 5

17 years ago
verifying based on reporter's comments
Status: RESOLVED → VERIFIED

Updated

10 years ago
Component: XP Toolkit/Widgets: Menus → XUL
QA Contact: jrgmorrison → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.