[v2.2] Investigate dialer test intermittent failures

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
4 years ago
2 years ago

People

(Reporter: RobertC, Assigned: jlorenzo)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8522335 [details]
logcat.txt

Dialer tests are failing on Jenkins with what seems to be the same screenshot.
http://jenkins1.qa.scl3.mozilla.com/view/UI/job/flame-kk-319.mozilla-b2g34_v2_1.ui.functional.non-smoke/62/HTML_Report/

We ran the tests locally without being able to reproduce this issue.
I also added the logcat from Jenkins (the section where one of the tests failed)

This issue cannot be reproduced manually and it requires further investigation.
QA Whiteboard: [fxosqa-auto-backlog+]
(Assignee)

Updated

4 years ago
QA Whiteboard: [fxosqa-auto-backlog+] → [fxosqa-auto-s8][fxosqa-auto-points=2]
(Assignee)

Updated

4 years ago
Assignee: nobody → jlorenzo
(Assignee)

Comment 1

4 years ago
At first, I would say that this screenshot is due to 2 different causes:
 * for test_dialer_set_up_conference_call: Plivo took so much time to place the call that the call to Mozilla's switchboard was hung up by the switchboard itself.
 * for test_dialer_receive_call_with_contact_photo: it seems like the contacts hadn't been pushed correctly.

I started 2 adhoc jobs to try reproducing them: http://jenkins1.qa.scl3.mozilla.com/view/UI/job/flame-kk.ui.adhoc/602/ http://jenkins1.qa.scl3.mozilla.com/view/UI/job/flame-kk.ui.adhoc/603/
(Assignee)

Comment 2

4 years ago
The second adhoc job failed due to bug 1117813. Plivo immediately hangs up that's why the StaleElementException is raised.
Depends on: 1117813
(Assignee)

Comment 3

4 years ago
The first adhoc job failed because of Plivo not able to place a call. Let's wait until bug 1117813 gets fixed.
QA Whiteboard: [fxosqa-auto-s8][fxosqa-auto-points=2] → [fxosqa-auto-dropped-s8][fxosqa-auto-points=2]
(Assignee)

Comment 4

2 years ago
Gaia UI tests are not run or maintained anymore.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.