Crash report dialog missing the name of the app that crashed - {{name}} just crashed

VERIFIED FIXED in Firefox OS v2.2

Status

Firefox OS
Gaia::System
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: marcia, Assigned: aus)

Tracking

unspecified
2.2 S3 (9jan)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [systemsfe])

Attachments

(2 attachments)

Created attachment 8522531 [details]
Screenshot of crash reporter dialog

Flame, while running:

Gaia   be8b0151d2f9a4c41fc63952128e0b723cd1161d
SourceStamp ab137ddd3746
BuildID 20141113040205
Version 36.0a1
v188

1. Crashed scrolling a page in browser
2. Observe the attached screenshot - Name of crashing app is missing
Summary: Crash report dialog missing the name of the app that crashed {{name}} just crashed → Crash report dialog missing the name of the app that crashed - {{name}} just crashed
blocking-b2g: --- → 2.2?
status-b2g-v2.2: --- → affected
This issue is caused by this line:

https://github.com/mozilla-b2g/gaia/blob/master/apps/system/js/crash_reporter.js#L157

If the app name is |null| then we will see |{{name}}| otherwise, the name of the app will be displayed or nothing if the app doesn't have name
blocking-b2g: 2.2? → 2.2+
Whiteboard: [systemsfe]
(Assignee)

Comment 2

3 years ago
Taking.
Assignee: nobody → aus
Target Milestone: --- → 2.2 S3 (9jan)
(Assignee)

Comment 3

3 years ago
Will start work on this this week.
Status: NEW → ASSIGNED
(Assignee)

Comment 4

3 years ago
Despite crashing the browser and other apps several times via kill, I've been unable to reproduce the issue. However, it's quite possible that 'app' that crashed has no name under certain circumstances. In this particular case, we should display something. I'm flagging UX for recommendations here.

My own suggestion, actually display 'something' making it 'Something just crashed.'
Flags: needinfo?(rmacdonald)
I'm fine with Aus's proposal. "Something just crashed." Thanks!
Flags: needinfo?(rmacdonald)
(Assignee)

Comment 6

3 years ago
Created attachment 8538850 [details] [review]
Pull Request - Use default app name when crashedAppName is null in CrashReporter

The only way to properly test this is via unit-tests. There are currently no unit-tests for the CrashReporter. I will add some basic tests before asking for review.
(Assignee)

Updated

3 years ago
Attachment #8538850 - Flags: review?(kgrandon)
Comment on attachment 8538850 [details] [review]
Pull Request - Use default app name when crashedAppName is null in CrashReporter

This seems fine to land for now as it's better than what we currently have. Ideally we would probably find a way to populate this with "Browser" in the future.
Attachment #8538850 - Flags: review?(kgrandon) → review+
In master: https://github.com/mozilla-b2g/gaia/commit/abca71dac6920898c5a9068e2bffc0877fd5f838
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
status-b2g-v2.2: affected → fixed
Resolution: --- → FIXED
Personally I would have gone with "The app", "This app", "Unidentified app".

Anyhow, is it possible to add a note in the localization file? Without the bug that "Something" doesn't make any sense.
Keywords: verifyme
I also think "Something" does not really make sense...

*2.2
Build ID               20150416162504
Gaia Revision          d50b8a3919a7b4d8d289f150d3b9bed704ebafa9
Gaia Date              2015-04-16 21:46:57
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/5ebf32030512
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150416.195720
Firmware Date          Thu Apr 16 19:57:29 EDT 2015
Bootloader             L1TC000118D0

*master
Build ID               20150416160206
Gaia Revision          3cd0a9facce26c2acc7be3755a17131a6358e33f
Gaia Date              2015-04-16 16:33:22
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/51e3cb11a258
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150416.191700
Firmware Date          Thu Apr 16 19:17:10 EDT 2015
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
status-b2g-v2.2: fixed → verified
status-b2g-master: --- → verified
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.