[e10s] Make cpow.navigator work with site-specific navigator fixup

RESOLVED FIXED in mozilla36

Status

()

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: mrbkap, Assigned: mrbkap)

Tracking

unspecified
mozilla36
Points:
---

Firefox Tracking Flags

(e10s?)

Details

Attachments

(2 attachments)

Current cpow.navigator.userAgent (in the child) calls into JS, which does a messagemanager.sendSyncMessage to the parent. Because we're already handling a high CPOW message, this aborts. For the moment, the best we can do is switch to using sendRpcMessage. khuey was complaining that we should weaken our assertions when there's a CPOW on the stack, but I don't want to deal with that here.

This was causing Tobias' nightly to crash in e10s mode because the "Blur" or "DoNotTrackMe" extension runs into this.
Created attachment 8522617 [details] [diff] [review]
patch v1

I'll attach a testcase for this tomorrow.
Attachment #8522617 - Flags: review?(wmccloskey)
Comment on attachment 8522617 [details] [diff] [review]
patch v1

Review of attachment 8522617 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks. Any chance you can add a test for this to test_cpows?

I don't think we should weaken the assertions. Each time we convert sendSyncMessage to sendRpcMessage, we need to be sure we're not breaking some ordering requirement. Weakening the assertions is essentially the same as converting them all without considering ordering.
Attachment #8522617 - Flags: review?(wmccloskey) → review+
Created attachment 8523222 [details] [diff] [review]
Add a test.
Attachment #8523222 - Flags: review?(wmccloskey)
Comment on attachment 8523222 [details] [diff] [review]
Add a test.

Review of attachment 8523222 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks!
Attachment #8523222 - Flags: review?(wmccloskey) → review+
Duplicate of this bug: 1095945
https://hg.mozilla.org/mozilla-central/rev/6039cbdd69a9
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla36
You need to log in before you can comment on or make changes to this bug.