The default bug view has changed. See this FAQ.

Content process crashes when doing "add to calendar" from an email in Gmail with Tree Style Tab enabled

RESOLVED FIXED

Status

()

Core
DOM: Content Processes
RESOLVED FIXED
2 years ago
6 months ago

People

(Reporter: njn, Unassigned)

Tracking

(Blocks: 1 bug)

unspecified
x86_64
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(e10s+, platform-rel ?)

Details

(Whiteboard: [amo-author-notified] [platform-rel-Google] [platform-rel-Gmail], URL)

(Reporter)

Description

2 years ago
I just tried doing "add to calendar" for a calendar request email in Gmail, and my content processes crashed. It seems to be repeatable. Here's the output I got on the console:

> ** (plugin-container:20672): CRITICAL **: gst_app_src_set_size: assertion 'GST_IS_APP_SRC (appsrc)' failed
> IPDL protocol error: Handler for CreateWindow returned error code
> 
> ###!!! [Parent][DispatchInterruptMessage] Error: (msgtype=0x1E0006,name=PBrowser::Msg_CreateWindow) Processing error: message was deserialized, but the handler returned false (indicating failure)
> 
> [Parent 2640] WARNING: pipe error (3): Connection reset by peer: file ../../../ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 457
> 
> ###!!! [Parent][MessageChannel] Error: Channel error: cannot send/recv

This is in a trunk build from yesterday.
(Reporter)

Updated

2 years ago
tracking-e10s: --- → ?
(Reporter)

Comment 1

2 years ago
I restarted the browser and it's still happening. My build is from mozilla-central ab137ddd3746.
(Reporter)

Comment 2

2 years ago
Still happens with mozilla-central revision a52bf59965a0. It seems to be related to something in my profile -- I tried two other profiles and I can't reproduce with them.
(Reporter)

Comment 3

2 years ago
I tried following the instruction at https://wiki.mozilla.org/Electrolysis/Debugging to debug the child. When the crash happened all I got was this:

> Program received signal SIGTERM, Terminated.
> pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
> 185 ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S: No such file or directory.
> (gdb) [Parent 411] WARNING: No docshells for remote frames!: file ../../../dom/base/nsFrameLoader.cpp, line 511

When I tried `bt` I just got this:

> #0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
> Cannot access memory at address 0x7fff1f97f468
(Reporter)

Comment 4

2 years ago
I get a crash also if I click on a username in Bugzilla and then select "Profile".
(Reporter)

Comment 5

2 years ago
Turns out this is a bad interaction between e10s and Tree Style Tab. If I disable either, the problem goes away.

So, steps to reproduce:

- Create a new profile in an e10s-enabled build of Firefox.

- Install Tree Style Tab from http://piro.sakura.ne.jp/xul/xpi/nightly/treestyletab.xpi.

- Restart.

- Log into Bugzilla.

- Click on a user name in Bugzilla and then select "Profile" from the dropdown

- The content process crashes.
Summary: Content process crashes when doing "add to calendar" from an email in Gmail → Content process crashes when doing "add to calendar" from an email in Gmail with Tree Style Tab enabled
Does anything appear in about:crashes?
(Reporter)

Comment 7

2 years ago
(In reply to Bill McCloskey (:billm) from comment #6)
> Does anything appear in about:crashes?

No.
Blocks: 905436, 1042680
tracking-e10s: ? → +

Comment 8

2 years ago
(In reply to Nicholas Nethercote [:njn] from comment #5)

Confirmed. target="_blank" seems to be a trigger of this crash.

Comment 9

2 years ago
After these changes, the crash problem reported on comment #5 seems to be fixed for me.
https://github.com/piroor/treestyletab/commit/66f16dde502f2d4c32b3ac4f346e0c88715e32af
https://github.com/piroor/treestyletab/commit/3663519efdfcf01d6717ade70b9ce56f935fa75b
https://github.com/piroor/treestyletab/commit/ddb87ab83ad9e86bf816659c430ded0b1dde5d29

Comment 10

2 years ago
This fix introduces a regression: if javascript opens all the links in a page

$('a').each(function() { window.open($(this).attr('href')); });

those links gets nested one to each other, instead of opening all as child of the parent tab.
I reverted to the previous version and confirmed that this behavior changes with the newest release.

Comment 11

2 years ago
This still does not appear to be working correctly for me, although it does not crash.
Whiteboard: [amo-author-notified]

Updated

a year ago
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WONTFIX
(Reporter)

Comment 12

a year ago
Jerod, you've recently marked two bugs I filed relating to add-ons as WONTFIX without any explanation: this one, and bug 1042965.

In my experience, this is not how these sorts of bugs is usually handled. Can you please explain why you did this? Thank you.
Flags: needinfo?(arenlor)

Comment 13

a year ago
(In reply to Nicholas Nethercote [:njn] (on PTO until January 4th) from comment #12)
> Jerod, you've recently marked two bugs I filed relating to add-ons as
> WONTFIX without any explanation: this one, and bug 1042965.
> 
> In my experience, this is not how these sorts of bugs is usually handled.
> Can you please explain why you did this? Thank you.

Sorry for my slow response. It was decided that with no dev response for 21 days that these bugs will be closed as WONTFIX.
Flags: needinfo?(arenlor)
(Reporter)

Comment 14

a year ago
> It was decided that with no dev response for 21 days that these bugs will be closed as WONTFIX.

"It was decided" -- who decided? Closing a bug like this just because there's no response is very much not the way things normally work in this Bugzilla. Unless there is evidence that the problem has been fixed, it should remain open.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
Whiteboard: [amo-author-notified] → [amo-author-notified] [platform-rel-Google] [platform-rel-Gmail]

Updated

9 months ago
platform-rel: --- → ?

Comment 15

6 months ago
Piro, it looks like the bug in comment 5 was fixed in comment 9. It then seems to change into another bug. How would like to proceed with this bug?
Flags: needinfo?(yuki)

Comment 16

6 months ago
I couldn't reproduce the problem anymore with the latest released version of TST 0.18.2016090802 on e10s-activated Nightly 51.0a1, Ubuntu 16.04LTS. I agree turn close this bug.
Flags: needinfo?(yuki)

Comment 17

6 months ago
Closing based on comment 16, if the original bug still occurs :njn, please let us know.
Status: REOPENED → RESOLVED
Last Resolved: a year ago6 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.