[Flame][Dialer] "#" key will always be highlighted after you input "*#06#" at dialer and then tap "X" to close IMEI view.

RESOLVED DUPLICATE of bug 1094896

Status

Firefox OS
Gaia::Dialer
RESOLVED DUPLICATE of bug 1094896
4 years ago
4 years ago

People

(Reporter: Sue, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.1 affected, b2g-v2.2 affected)

Details

Attachments

(4 attachments)

(Reporter)

Description

4 years ago
Created attachment 8522794 [details]
video for dialer

[1.Description]:
[Flame v2.1&v2.2]
When you tap "*#06#" at dialer and tap X" to back dialer, there is a highlight of "#", and when you tap other keys, the highlight isn't disappear until you tap "#" key.
See attachment(1103.mp4 and logcat_1103.txt)
Found time:11:03

[2.Testing Steps]: 
1. Launch dialer.
2. Tap "*#06#".
**The IMEI of device show up.
3. Tap "X" at left top.
4. Tap on other keys.

[3.Expected Result]: 
3.  "#" should not be highlighted.
4. The highlight of "#" should disappear.

[4.Actual Result]: 
3.  "#" key is highlighted .
4. The highlight on  "#" key will  not disappear.

[5.Reproduction build]: 
Flame 2.1 versions:
Gaia-Rev        569a299ca446f714cd98d5881cc058fd6f6e257b
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/d188e92aa5a6
Build-ID        20141113001200
Version         34.0

Flame 2.2 versions:
Gaia-Rev        be8b0151d2f9a4c41fc63952128e0b723cd1161d
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/ab137ddd3746
Build-ID        20141113040205
Version         36.0a1

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.Note]
When open Bluetooth and searching device, tap "Search for device" which is gray, there is a highlight of "Search for device". After finish search, tap Search for device again, the highlight isn't gone.
**This issue only happen on Flame v2.1.
See attachment(2301.mp4 and logcat_2301.txt)
Found time:23:01
(Reporter)

Comment 1

4 years ago
Created attachment 8522795 [details]
logcat for dailer
(Reporter)

Comment 2

4 years ago
Created attachment 8522798 [details]
video for bluetooth(7.Note)
(Reporter)

Comment 3

4 years ago
Created attachment 8522801 [details]
logcat for bluetooth(7.Note)
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1094896
You need to log in before you can comment on or make changes to this bug.