Closed Bug 1099104 Opened 5 years ago Closed 5 years ago

Regression: content not sized correctly in viewport

Categories

(Firefox for Android :: Toolbar, defect)

36 Branch
ARM
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 36
Tracking Status
firefox33 --- unaffected
firefox34 --- unaffected
firefox35 --- unaffected
firefox36 --- verified
fennec 36+ ---

People

(Reporter: TeoVermesan, Assigned: botond)

References

Details

(Keywords: regression, reproducible)

Attachments

(4 files)

Attached image about:firefox
Tested with:
Build: Firefox for Android 36.0a1 (2014-11-14)
Device: LG Nexus 4 (Android 4.4)

Steps to reproduce:
1. Open Firefox
2. Go to about:firefox

Expected results:
- The page is aligned to center.

Actual results:
- The page is aligned to left.

Regression window:
Last good: 2014-11-13
First bad: 2014-11-14

Pushlog: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=ab137ddd3746&tochange=7f0d92595432
Attached image zoom-out
Also after going to news.google.com, open an article, zoom out the page as much as you can, the page is aligned left, with a blank portion on the right side.
https://hg.mozilla.org/integration/fx-team/pushloghtml?fromchange=8bbf5db85ada&tochange=7f0d92595432

Bug 1076163?
tracking-fennec: --- → ?
Keywords: regression
Summary: about:firefox page is aligned to left → Regression: content not sized correctly in viewport
Flags: in-testsuite?
Component: General → Graphics, Panning and Zooming
Flags: needinfo?(botond)
It's either bug 1076163 or bug 1055741, narrowed it down to those two with inbound builds.
Local build still has the problems if I go to cset 9106c8d44533, so it's definitely bug 1076163. I'm bisecting within the two patches to see if I can find the culprit. I looked over the patches again and I don't see anything that should be causing this.
Keywords: reproducible
It's in the part 1 patch. I think it's because the code assumes aContainerParameters.m[XY]Scale includes the full cumulative resolution but I don't think it does. It's just the resolution+CSSextra scale for the current layer. So we probably need to multiply the ancestor presShell resolutions into that manually.
Attached patch Possible fixSplinter Review
Not quite that, but definitely something with the aContainerParameters not being what we expect. For example, after loading people.mozilla.org/~kgupta/grid.html and zooming in, I would expect the aContainerParameters scale to go up but it stays at 1.0. This patch seems to fix the problem on Fennec, but I don't know if it regresses B2G:
Attached patch Temporary fixSplinter Review
Thanks for diagnosing this, Kats!

Here's a temporary fix which should restore normal rendering for pages that don't have CSS transforms; pages that have CSS transforms might still be rendered wrong, but no worse than before bug 1076163.

I tested locally and this patch fixes the STR from comment 0; I could not reproduce the STR from comment 1 (I could not zoom out any articles from news.google.com to begin with).
Assignee: nobody → botond
Flags: needinfo?(botond)
Attachment #8523093 - Flags: review?(bugmail.mozilla)
Comment on attachment 8523093 [details] [diff] [review]
Temporary fix

Review of attachment 8523093 [details] [diff] [review]:
-----------------------------------------------------------------

Works for me!
Attachment #8523093 - Flags: review?(bugmail.mozilla) → review+
Landed temporary fix: https://hg.mozilla.org/integration/mozilla-inbound/rev/7876dacf7ee2

Sorry for the regression!
Botond - Can you file a new bug to fix the "TODO" ?
Flags: needinfo?(botond)
If you're looking for content to reproduce, http://nightly.mozilla.org
See Also: → 1099298
(In reply to Mark Finkle (:mfinkle) from comment #10)
> Botond - Can you file a new bug to fix the "TODO" ?

Filed bug 1099298.
Flags: needinfo?(botond)
https://hg.mozilla.org/mozilla-central/rev/7876dacf7ee2
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 36
On latest Nightly (2014-11-16) about:firefox is aligned to center. Also accessing news.google.com, open an article, zoom in and zoom out, the page is rendered correctly.
Status: RESOLVED → VERIFIED
tracking-fennec: ? → 36+
Based on my comment #14 i will mark status-firefox36 from fixed to verified
You need to log in before you can comment on or make changes to this bug.