Closed Bug 1099151 Opened 6 years ago Closed 6 years ago

Can not copy to clipboard using 'Ctrl + C' on html5 youtube videos

Categories

(Core :: General, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1052569
Tracking Status
firefox33 --- affected
firefox34 --- affected
firefox35 --- affected
firefox36 --- affected

People

(Reporter: cos_flaviu, Unassigned)

Details

Attachments

(1 file)

Attached image screenshot.jpg
Reproducible on the latest Nightly (BuildID: 20141113030201): 
Mozilla/5.0 (X11; Linux i686; rv:36.0) Gecko/20100101 Firefox/36.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:36.0) Gecko/20100101 Firefox/36.0
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:36.0) Gecko/20100101 Firefox/36.0

Steps to reproduce:
1. Go to youtube.com/html5
2. Make sure that the HTML5 player is currently used when possible.
3. Go back to youtube.com
4. Click to play on any video;
5. Right click on the video;
6. Choose 'Get video URL' option from the context menu;
7. Press 'Ctrl + C' to copy the URL to clipboard;
8. Press 'Ctrl + V' in the url bar.

Expected results:
The URL is successfully copied to clipboard and can be pate anywhere.

Actual results:
The url can not be copied to clipboard using 'Ctrl + C'.

Notes:
Was not enable to determine reliable regression window.
34 is affected... is 33?
Flags: needinfo?(flaviu.cos)
Product: Firefox → Core
(and are we sure this isn't youtube blocking keypresses or something silly?)
(In reply to :Gijs Kruitbosch from comment #1)
> 34 is affected... is 33?
Yes, 33.1.1 is also affected.

(In reply to :Gijs Kruitbosch from comment #2)
> (and are we sure this isn't youtube blocking keypresses or something silly?)
Works fine on Internet Explorer an Google Chrome.
Flags: needinfo?(flaviu.cos)
(In reply to Flaviu Cos, QA [:flaviu] from comment #3)
> (In reply to :Gijs Kruitbosch from comment #1)
> > 34 is affected... is 33?
> Yes, 33.1.1 is also affected.

OK, so at least it's not a new regression we're shipping compared to current release...

> (In reply to :Gijs Kruitbosch from comment #2)
> > (and are we sure this isn't youtube blocking keypresses or something silly?)
> Works fine on Internet Explorer an Google Chrome.

That doesn't really answer the question, unfortunately.
This is because youtube calls preventDefault() on the keypress event for the ctrl/cmd-c. Simple testcase:

http://jsbin.com/yayikikaka/1/edit?html,js,output

which makes this a dupe.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1052569
Thinking about this more... Karl, do we have contacts at youtube to get this addressed on their end? They really shouldn't be calling preventDefault on keypresses with modifier keys pressed.
Flags: needinfo?(kdubost)
Youtube/Google has been contacted.
Flags: needinfo?(kdubost)
You need to log in before you can comment on or make changes to this bug.