Closed Bug 1099462 Opened 5 years ago Closed 5 years ago

Set the Getting Started URL for Loop

Categories

(Hello (Loop) :: Client, defect, P1)

defect
Points:
3

Tracking

(firefox35 fixed, firefox36 fixed)

RESOLVED FIXED
mozilla36
Iteration:
36.3
Tracking Status
firefox35 --- fixed
firefox36 --- fixed
Blocking Flags:
backlog Fx35+

People

(Reporter: jaws, Assigned: jaws)

References

Details

(Whiteboard: [FTE][good first verify])

Attachments

(1 file)

Bug 1083466 is using a temporary URL until we get the official one. This bug is to set the official one.
Flags: qe-verify+
Flags: firefox-backlog+
backlog: --- → Fx35+
Priority: -- → P1
Hi Cory, who should this be assigned to until the URL is determined and Jared is told?
Flags: needinfo?(cprice)
Whiteboard: [FTE]
Hi Shell,

I've assigned this to myself.

Once the parameters from analytics have been set, I will update this bug.

Thank you
Assignee: nobody → cprice
Flags: needinfo?(cprice)
Thanks. I've closed bug 1101286 and will handle updating both sources in this bug.
Assignee: cprice → jaws
Status: NEW → ASSIGNED
Points: 1 → 3
Flags: needinfo?(jaws)
Iteration: --- → 36.3
Attached patch PatchSplinter Review
Attachment #8526430 - Flags: review?(MattN+bmo)
Hi Marco, can you please add this bug to the tracker for 36.3? Thanks!
Flags: needinfo?(mmucci)
Added to IT 36.3
Flags: needinfo?(mmucci)
Comment on attachment 8526430 [details] [diff] [review]
Patch

Review of attachment 8526430 [details] [diff] [review]:
-----------------------------------------------------------------

r=me but I think it would be good to see if Corey wants to change this today.

::: browser/components/loop/content/js/panel.jsx
@@ +165,5 @@
>    });
>  
>    var GettingStartedView = React.createClass({
>      handleButtonClick: function() {
> +      navigator.mozLoop.openGettingStartedTour("doorhanger");

I personally think "doorhanger" is an implementation detail and also confusing since the settings-menu is also in the "doorhanger". I think a better name would be something like "getting-started".
Attachment #8526430 - Flags: review?(MattN+bmo)
Attachment #8526430 - Flags: review+
Attachment #8526430 - Flags: feedback?(cprice)
Hi MattN,

That'll work, thanks!
Comment on attachment 8526430 [details] [diff] [review]
Patch

Review of attachment 8526430 [details] [diff] [review]:
-----------------------------------------------------------------

"getting-started" would work in place of "doorhanger" for the utm_campaign parameter. Thank you.
Thanks, I'll make the switch before landing.
Attachment #8526430 - Flags: feedback?(cprice)
https://hg.mozilla.org/mozilla-central/rev/bfc68d26c7da
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Whiteboard: [FTE][fixed-in-fx-team] → [FTE]
Target Milestone: --- → mozilla36
We won't verify this bug specifically, this bug will be verified in part through testing the meta bug.
Flags: qe-verify+ → qe-verify-
Comment on attachment 8526430 [details] [diff] [review]
Patch

Approval Request Comment
[Risks and why]: Loop rooms code needed for 35 pref-on
[String/UUID change made/needed]: none
Attachment #8526430 - Flags: approval-mozilla-aurora?
Attachment #8526430 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Flags: in-moztrap-
Whiteboard: [FTE] → [FTE][good first verify]
Duplicate of this bug: 1101286
You need to log in before you can comment on or make changes to this bug.