Crash in mozilla::MediaDecoderReader::RequestVideoData

RESOLVED WORKSFORME

Status

()

Core
Audio/Video
RESOLVED WORKSFORME
4 years ago
3 years ago

People

(Reporter: Trevor Rowbotham, Assigned: handyman)

Tracking

(Blocks: 1 bug, {crash})

Trunk
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

4 years ago
I don't have any reliable steps to reproduce.  Was just watching a YouTube video and playback kept stuttering/stalling and then it would eventually just crash.  Video was using MSE + MP4.

bp-059e45eb-d08f-4511-a374-e97042141116
bp-45e2691e-dc07-4262-94ba-a9dd72141116
Assignee: nobody → davidp99
(Assignee)

Comment 1

4 years ago
(In reply to Trevor Rowbotham from comment #0)
> I don't have any reliable steps to reproduce.  Was just watching a YouTube
> video and playback kept stuttering/stalling and then it would eventually
> just crash.  Video was using MSE + MP4.

I haven't had any luck reproducing this.  Any chance you've seen it again?  I've been jumping around MP4 youtube videos for a while and it seems to be behaving well for me (on Windows 8).

Do you have any addons/plugins installed?  And have you changed any about:config settings - you never know what will turn out to be relevant.  (You can just cut-and-paste your troubleshooting info from about:support here.)
(Assignee)

Comment 2

4 years ago
(See comment 1)
Flags: needinfo?(smokey101stair)
(Reporter)

Comment 3

4 years ago
I ran into this again yesterday: bp-2b7c298a-6334-4dcd-9a8c-c9d5b2141119
What happened this time was that the video froze, but the audio kept playing. I seeked forward a few seconds to get the video started again and it crashed a few seconds after seeking.

I will try testing this with a clean profile to see if I can reproduce it there.

Extensions
----------

Name: about:addons-memory
Version: 10
Enabled: true
ID: about-addons-memory@tn123.org

Name: Adblock Plus
Version: 2.6.6.3877
Enabled: true
ID: {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}

Name: Firefogg
Version: 330
Enabled: true
ID: firefogg@firefogg.org

Name: Screengrab (fix version)
Version: 0.98.03c
Enabled: true
ID: {02450914-cdd9-410f-b1da-db004e18c671}

Name: X-notifier
Version: 3.5.1
Enabled: true
ID: {37fa1426-b82d-11db-8314-0800200c9a66}

Name: ADB Helper
Version: 0.7.1
Enabled: false
ID: adbhelper@mozilla.org

Name: Bookmark Duplicate Cleaner
Version: 0.2
Enabled: false
ID: bookmarkdup@localghost.net

Name: checkCompatibility
Version: 1.3
Enabled: false
ID: check-compatibility@dactyl.googlecode.com

Name: Click to Play per-element
Version: 0.0.7
Enabled: false
ID: ClickToPlayPerElement@uaSad.addons.mozilla.org

Name: Disconnect
Version: 3.14.0
Enabled: false
ID: 2.0@disconnect.me

Name: DOM Inspector
Version: 2.0.14
Enabled: false
ID: inspector@mozilla.org

Name: Gecko Profiler
Version: 1.14.2
Enabled: false
ID: jid0-edalmuivkozlouyij0lpdx548bc@jetpack

Name: Greasemonkey
Version: 2.3
Enabled: false
ID: {e4a8a97b-f2ed-450b-b12d-ee082ba24781}

Name: Page Speed
Version: 1.12.9.2
Enabled: false
ID: {e3f6c2cc-d8db-498c-af6c-499fb211db97}

Name: YouTube Center Developer Build
Version: 419
Enabled: false
ID: jid1-cwbvBTE216jjpg@jetpack

Graphics
--------

Adapter Description: NVIDIA GeForce GTX 660
Adapter Drivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
Adapter RAM: 2048
Device ID: 0x11c0
Direct2D Enabled: true
DirectWrite Enabled: true (6.2.9200.16571)
Driver Date: 11-3-2014
Driver Version: 9.18.13.4465
GPU #2 Active: false
GPU Accelerated Windows: 2/2 Direct3D 11 (OMTC)
Subsys ID: 30693842
Vendor ID: 0x10de
WebGL Renderer: Google Inc. -- ANGLE (NVIDIA GeForce GTX 660 Direct3D11 vs_5_0 ps_5_0)
windowLayerManagerRemote: true
AzureCanvasBackend: direct2d 1.1
AzureContentBackend: direct2d 1.1
AzureFallbackCanvasBackend: cairo
AzureSkiaAccelerated: 0

Important Modified Preferences
------------------------------

accessibility.typeaheadfind.flashBar: 0
browser.cache.disk.capacity: 358400
browser.cache.disk.smart_size_cached_value: 358400
browser.cache.disk.smart_size.first_run: false
browser.cache.disk.smart_size.use_old_max: false
browser.cache.frecency_experiment: 4
browser.places.smartBookmarksVersion: 7
browser.search.useDBForOrder: true
browser.sessionstore.upgradeBackup.latestBuildID: 20141119030200
browser.startup.homepage: about:newtab
browser.startup.homepage_override.buildID: 20141119030200
browser.startup.homepage_override.mstone: 36.0a1
browser.tabs.remote.autostart: true
browser.tabs.remote.autostart.1: false
browser.tabs.warnOnOpen: false
dom.abortablepromise.enabled: true
dom.image.picture.enabled: true
dom.image.srcset.enabled: true
dom.mozApps.used: true
dom.w3c_pointer_events.enabled: true
dom.webcomponents.enabled: true
extensions.checkCompatibility.31.0a: true
extensions.checkCompatibility.nightly: true
extensions.lastAppVersion: 36.0a1
font.internaluseonly.changed: false
gfx.direct3d.last_used_feature_level_idx: 0
layers.offmainthreadcomposition.testing.enabled: true
media.mediasource.webm.enabled: true
media.openh264.enabled: false
media.track.enabled: true
network.cookie.prefsMigrated: true
places.database.lastMaintenance: 1416354657
places.history.expiration.transient_current_max_pages: 53617
plugin.disable_full_page_plugin_for_types: application/pdf
plugin.importedState: true
plugin.state.flash: 1
plugin.state.npauthz: 0
plugin.state.npbattlelog: 2
plugin.state.npdeployjava: 0
plugin.state.npesnsonar: 2
plugin.state.npqtplugin: 1
plugin.state.npspwrap: 0
privacy.donottrackheader.enabled: true
privacy.sanitize.migrateFx3Prefs: true
privacy.trackingprotection.enabled: true
privacy.trackingprotection.ui.enabled: true
security.dialog_enable_delay: 0
storage.vacuum.last.index: 1
storage.vacuum.last.places.sqlite: 1414174232
svg.new-getBBox.enabled: true
webgl.angle.try-d3d11: true
webgl.enable-draft-extensions: true
Flags: needinfo?(smokey101stair)
(Assignee)

Comment 4

4 years ago
Thanks for putting some effort into this.  I'm trying youtube videos with some of your settings but still no luck so far.  Also, are you sure the videos were MP4?  You have webm turned on so most (but not all) youtube videos would be webm.  I haven't seen the crash yet for mp4 or webm though.
(Reporter)

Comment 5

4 years ago
I was able to get this to crash in a clean profile just now [1], which should rule out modified prefs, plugins, and addons being the cause. 

Still no solid steps to reproduce. It was difficult to get it to occur today.  I had to refresh the page a bunch of times (since MP4 files with MSE won't replay after they have ended on YouTube) and seeking a bunch of times to run into this.

Yes, I am certain it was MP4.  At the time of the crashes, I had media.mediasource.webm.enabled set to false. I changed it back to true earlier today since I was having trouble with MP4s. Sorry about the confusion there.

I haven't seen this crash with webm videos yet.

[1] bp-a0749dec-6700-4b85-ac37-9c2482141119
(Assignee)

Comment 6

4 years ago
All of that is helpful.  Thanks - I'll see what I can do with it.
(Assignee)

Updated

4 years ago
tracking-e10s: --- → ?

Updated

4 years ago
Keywords: crash
(Assignee)

Comment 7

4 years ago
Even with the instructions to refresh the page and skip around, I can't seem to get this crash.  (I don't have the problem where mp4 videos can't be replayed but I've been refreshing anyway.)

I'm looking at similar crashes.  It looks like this issue probably popped up just before November 8th:

https://crash-stats.mozilla.com/report/list?product=Firefox&range_unit=days&range_value=28&signature=mozilla%3A%3AMediaDecoderReader%3A%3ARequestVideoData%28bool%2C+__int64%29#tab-reports

If true, this narrows down the issue.  I'm currently thinking that the patches from bug 1065827 look related and are the right time frame.  I might need to ask you to try to repeat this with the nightly from Nov 6th.  (I know you don't have a reliable repro but I haven't seen this at all so I can't do it myself.)

http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2014-11-06-03-02-01-mozilla-central/firefox-36.0a1.en-US.win32.installer.exe

But before that, how sure are you that this is e10s related?  When you get a chance could you try reproducing (with your current nightly browser) in a non-e10s window?
Flags: needinfo?(smokey101stair)
(Reporter)

Comment 8

4 years ago
I will give the Nov 6th build a try to see if I can reproduce it.

I cannot confirm that this is exclusive to e10s.  I will try to reproduce this in a non-e10s window as well.

I am on Windows 7, which may or may not make a difference.

I'm also curious as to why MP4 videos can't be replayed for me without refreshing the page, but works for you. I'll file a different bug for this problem in a bit.
Flags: needinfo?(smokey101stair)
(Reporter)

Comment 9

4 years ago
I was able to get firefox to crash in a non-e10s window with a nearly identical crash signature: bp-219c839a-caa3-41e3-a54c-3a7c32141120.

I also got a few other different crashes that appear to be related to the MP4 backend while trying to reproduce this bug.  I don't know how relevant they are to this particular crash, but I'm going to include them just incase.
bp-b75a193d-c509-4dbb-93ed-e172e2141120
bp-c48c2d76-e5d3-4ff7-b5be-7e37a2141120
bp-39dc5ad7-dedb-4274-b2c8-87ec32141120

I am having some difficulty testing in the Nov 6th build since Youtube doesn't want to serve MP4s to me even though I have media.mediasource.ignore_codecs = true and media.webm.enabled = false set.
(Assignee)

Comment 10

4 years ago
OK... this is going to be more involved than I thought.  Many thanks for putting in the effort, Trevor.

jya, can someone on the media team look into this?  The issue doesn't seem to be e10s-related.  The crash stats (comment 7) clearly implicate something that went in just before Nov 8th, but that does include a lot of work (including a lot of media work).  The other crashes in comment 9 aren't immediately clearly related but at least all seem to be memory issues (and the last two appear to have popped up around Nov 13th).
tracking-e10s: ? → ---
Flags: needinfo?(jyavenard)
Summary: [e10s] crash in mozilla::MediaDecoderReader::RequestVideoData → Crash in mozilla::MediaDecoderReader::RequestVideoData
(Reporter)

Comment 11

4 years ago
Thanks for taking the time to look into this.  I did eventually find a youtube video that was MP4 using the Nov 6th build, but I wasn't able to reproduce it on that build during the hour I spent trying to get it to happen. So I think it is reasonable to assume that this crash did not occur in earlier builds.

I'll file bugs on those other crash reports later today as well as the video not replaying issue.
Do you still have this issue?

I only experience one consistent crash when seeking with MSE+MP4, which patch from bug 1105553 fixes
Flags: needinfo?(jyavenard)
(Reporter)

Comment 13

4 years ago
I have been using MSE+Webm for the past week due to MSE+MP4 issues, so its hard to say whether this is still a problem.  According to crash stats, there were 65 crashes with this signature in the last 7 days, with the last reported build being 2014-11-21.  I will turn MSE+MP4 back on this week and test, although I think it may be safe to close this based on the fact that no crashes with this signature have been reported since the 21st.
Blocks: 778617
(Reporter)

Comment 14

3 years ago
I switched back to MSE+MP4 and I have not seen this crash since I last reported it, and crash stats still doesn't show this having happened on any builds since 2014-11-21.  I am going to go ahead and close this bug as I can no longer reproduce it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.