firefox does not remember added entries to open with dialogue

RESOLVED DUPLICATE of bug 369431

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 369431
4 years ago
4 years ago

People

(Reporter: illumilor.e, Unassigned)

Tracking

33 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:33.0) Gecko/20100101 Firefox/33.0
Build ID: 2014101000

Steps to reproduce:

When opening a torrent file, an open with box come up, and I select open with other, then I choose the program to open it with.


Actual results:

 Then I click on a different torrent link, and the entry that I just choose is not present in the open with list. Nor is the entry that firefox calls the default even auto selected in entry list.


Expected results:

The app that I manually selected from other... should be remembered in the list when it next comes back up. Also, the default app should be preselect when the open with window comes up.

Comment 1

4 years ago
Can you link to a site to test this on? Ideally somewhere legal? (linux distros do torrents these days, assuming you can reproduce the issue there)

Note that if the mimetype the website provides is application/octet-stream, that this is unlikely to be fixable on Firefox's side...
Flags: needinfo?(illumilor.e)
(Reporter)

Comment 2

4 years ago
It happens on this torrent: http://itvends.com/gapps/gapps-kk-20140606-signed.zip.torrent

Why does it being application/octet-stream mean that FF is unable to keep any added entries to the list?
Flags: needinfo?(illumilor.e)

Comment 3

4 years ago
(In reply to illumilor.e from comment #2)
> It happens on this torrent:
> http://itvends.com/gapps/gapps-kk-20140606-signed.zip.torrent
> 
> Why does it being application/octet-stream mean that FF is unable to keep
> any added entries to the list?

I *think* this is effectively a duplicate of bug 369431, and I was wrong about not being able to fix it, per se.

The reason application/octet-stream is magical is that it normally means something is a binary blob (usually executable). In any case, AIUI bug 347230 advocates having a way to override this behaviour and use "open with" anyway - but helper apps, mime types and extensions are hairy things. :-\
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 369431
You need to log in before you can comment on or make changes to this bug.