MediaCodecReader crash at MediaCodecReader::ReleaseMediaResources().

RESOLVED DUPLICATE of bug 1033903

Status

()

Core
Audio/Video
RESOLVED DUPLICATE of bug 1033903
3 years ago
3 years ago

People

(Reporter: bechen, Assigned: bechen)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

3 years ago
STR:
Enable MediaCodec preference.
Open a HTTP streaming by browser, then press back quickly.


#0  0x000092ce in mozalloc_abort (msg=<optimized out>) at ../../../../../../hg/mozilla-central/memory/mozalloc/mozalloc_abort.cpp:37
#1  0xb4c8891e in __android_log_assert (cond=0xb4d88552 "!(mStarted)", tag=0xb4d8e6e2 "MPEG4Extractor", fmt=0xb4d83457 "%s") at system/core/liblog/logd_write.c:261
#2  0xb4d1f59e in stop (this=<optimized out>) at frameworks/av/media/libstagefright/MPEG4Extractor.cpp:2604
#3  android::MPEG4Source::stop (this=0xb16a8c40) at frameworks/av/media/libstagefright/MPEG4Extractor.cpp:2601
#4  0xb5a186e6 in mozilla::MediaCodecReader::ReleaseMediaResources (this=0xb0ba1800) at /home/benjamin/Documents/hg/mozilla-central/dom/media/omx/MediaCodecReader.cpp:325
#5  0xb59c28fa in mozilla::MediaDecoderStateMachine::RunStateMachine (this=0xb0ba2c00) at /home/benjamin/Documents/hg/mozilla-central/dom/media/MediaDecoderStateMachine.cpp:2510
#6  0xb59afa9a in mozilla::MediaDecoderStateMachineScheduler::TimeoutExpired (this=0xb0c50b80, aTimerId=4)
    at /home/benjamin/Documents/hg/mozilla-central/dom/media/MediaDecoderStateMachineScheduler.cpp:160
#7  0xb519669c in nsThreadPool::Run (this=0xaffe7fb0) at ../../../../../../hg/mozilla-central/xpcom/threads/nsThreadPool.cpp:220
#8  0xb5194180 in nsThread::ProcessNextEvent (this=0xb0630e80, aMayWait=<optimized out>, aResult=0xb1783d27) at ../../../../../../hg/mozilla-central/xpcom/threads/nsThread.cpp:830
#9  0xb51a1daa in NS_ProcessNextEvent (aThread=<optimized out>, aMayWait=aMayWait@entry=false) at /home/benjamin/Documents/hg/mozilla-central/xpcom/glue/nsThreadUtils.cpp:265
#10 0xb52e5bc6 in mozilla::ipc::MessagePumpForNonMainThreads::Run (this=0xb060a280, aDelegate=0xb169f6e0) at ../../../../../../hg/mozilla-central/ipc/glue/MessagePump.cpp:339
#11 0xb52da5d4 in MessageLoop::RunInternal (this=this@entry=0xb169f6e0) at ../../../../../../hg/mozilla-central/ipc/chromium/src/base/message_loop.cc:233
#12 0xb52da688 in RunHandler (this=0xb169f6e0) at ../../../../../../hg/mozilla-central/ipc/chromium/src/base/message_loop.cc:226
#13 MessageLoop::Run (this=this@entry=0xb169f6e0) at ../../../../../../hg/mozilla-central/ipc/chromium/src/base/message_loop.cc:200
#14 0xb51969a8 in nsThread::ThreadFunc (aArg=0xb0630e80) at ../../../../../../hg/mozilla-central/xpcom/threads/nsThread.cpp:350
#15 0xb6e2e052 in _pt_root (arg=0xb064c300) at ../../../../../../../../hg/mozilla-central/nsprpub/pr/src/pthreads/ptthread.c:212
#16 0xb6e9e22c in __thread_entry (func=0xb6e2dfb9 <_pt_root>, arg=0xb064c300, tls=0xb1783dd0) at bionic/libc/bionic/pthread_create.cpp:105
#17 0xb6e9e3c4 in pthread_create (thread_out=0xbe8723ec, attr=<optimized out>, start_routine=0xb6e2dfb9 <_pt_root>, arg=0x78) at bionic/libc/bionic/pthread_create.cpp:224
#18 0x00000000 in ?? ()

Comment 1

3 years ago
Hi Benjamin,

This crash probably has been fixed by the patch on bug 1033903 already.
Would you mind using the latest gecko to try it again?
(Assignee)

Comment 2

3 years ago
(In reply to Bruce Sun [:brsun] from comment #1)
> Hi Benjamin,
> 
> This crash probably has been fixed by the patch on bug 1033903 already.
> Would you mind using the latest gecko to try it again?

You are right, I'll try it later then close it.
(Assignee)

Updated

3 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1033903
You need to log in before you can comment on or make changes to this bug.