Refresh Firefox button is missing using a new profile different from dev-edition default profile

RESOLVED WORKSFORME

Status

()

defect
P2
normal
RESOLVED WORKSFORME
5 years ago
3 months ago

People

(Reporter: bogdan_maris, Unassigned)

Tracking

(Blocks 2 bugs)

35 Branch
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [iris])

STR:
1. Start Aurora/Developer Edition with a new profile different from 'dev-edition default' profile automatically created.
2. Go to about:support

Expected results: All buttons are activated in the page.

Actual results: Refresh Firefox button is missing from the page.

Notes:
1. This is reproducible on all platforms.
Just to note I'm also able to see that problem sometimes in Nightly on Ubuntu 14.10. After another restart the box for resetting the profile is shown again. I haven't seen a pattern for that yet.
I believe this button only appears for the "default" profile (and I believe the Developer Edition will consider its dev-edition-default profile as the default profile even though it's technically not marked as the default.)

So that doesn't explain comment 1 but *might* explain comment 0.

Comment 3

4 years ago
Mark's comment #2 is on the money.

(In reply to Henrik Skupin (:whimboo) from comment #1)
> Just to note I'm also able to see that problem sometimes in Nightly on
> Ubuntu 14.10. After another restart the box for resetting the profile is
> shown again. I haven't seen a pattern for that yet.

I expect this is because you launch Firefox by specifying a profile from the commandline, which doesn't change the default profile (whereas if you open the profile manager and pick one, that does change the default profile). Could that be the case?

In any case, it seems like the devedition bug should be fixed irrespective of figuring out the cause for comment #1.
Going through the profile manager or selecting a specific profile via the command line with the -p option, doesn't make a difference right after start. Both ways show the button.
So one thing I noticed with the dev edition is that when I start it via the icon in the Launcher (Ubuntu 14.10) the button is not present. But it is visible via the both ways from above.
(In reply to Henrik Skupin (:whimboo) from comment #5)
> So one thing I noticed with the dev edition is that when I start it via the
> icon in the Launcher (Ubuntu 14.10) the button is not present. But it is
> visible via the both ways from above.

https://dxr.mozilla.org/mozilla-central/source/toolkit/modules/ResetProfile.jsm#21 is the check in question - it would be good to know how that acts in a browser scratchpad.
and it's even possible that:

let ps = Cc["@mozilla.org/toolkit/profile-service;1"]
         .getService(Ci.nsIToolkitProfileService);
ps.selectedProfile == ps.defaultProfile

would be a better check - IIRC, .defaultProfile post-dates ResetProfile.jsm
Just another data point - on a dev edition install on OSX 10.8, I do see the 'refresh firefox developer edition' button in about:support when running with all of these profiles while starting with the profile manager:

"dev-edition-default"
"default"
"test" <- brand new profile

However, when running with the -p flag I don't see the button in any of those profiles.
(In reply to Brian Grinstead [:bgrins] from comment #8)
> "test" <- brand new profile

That's because new profiles also get Default=1.

We're running into this bug in Iris test case automation. Is there any setting/preference in the profile that can be set as a work around?

Summary: Refresh Firefox button is missing using a new profile different from dev-edition default profile → {iris} Refresh Firefox button is missing using a new profile different from dev-edition default profile
Summary: {iris} Refresh Firefox button is missing using a new profile different from dev-edition default profile → Refresh Firefox button is missing using a new profile different from dev-edition default profile
Whiteboard: iris
Whiteboard: iris → [iris]
Component: General → General
Priority: -- → P2
Product: Firefox → Toolkit

Comment 11

3 months ago

I suspect this bug as filed was fixed in bug 1265368. Bogdan, can you (find someone to) verify?

(In reply to Tracy Walker [:tracy] from comment #10)

We're running into this bug in Iris test case automation. Is there any setting/preference in the profile that can be set as a work around?

I don't know what Iris is, but if the profile you're running is in profiles.ini and has a name, and the running copy of Firefox is aware of that, reset should work. If you're using a temporary profile (e.g. by passing a profile dir instead of a profile name (or nothing, to use the default profile) when starting Firefox), you can accomplish this from within the runtime. There's a python marionette test for this behavior, and this set of code:

https://searchfox.org/mozilla-central/rev/c3ebaf6de2d481c262c04bb9657eaf76bf47e2ac/browser/components/migration/tests/marionette/test_refresh_firefox.py#524-545

shows how to do this.

Note that Fx Reset/Refresh creates files on the desktop etc., and this type of manipulation alters profiles.ini on the machine, and so you should be careful to restore those changes to avoid messing with other Firefox/Nightly/whatever profiles on the machine. Feel free to ask me (probably via email instead of this bug) if you need more help with this.

Flags: needinfo?(bogdan.maris)

(In reply to :Gijs (he/him) from comment #11)

I suspect this bug as filed was fixed in bug 1265368. Bogdan, can you (find someone to) verify?

Fixed now in latest DevEd 65.0b9 across platforms (Windows 10 64bit, macOS 10.13 and Ubuntu 18.04 64bit).

Status: NEW → RESOLVED
Last Resolved: 3 months ago
Flags: needinfo?(bogdan.maris)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.