favicon pref needs gui hookup

RESOLVED WONTFIX

Status

SeaMonkey
General
RESOLVED WONTFIX
17 years ago
14 years ago

People

(Reporter: James Paige, Assigned: James Paige)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

17 years ago
Well, now that the controversial new browser.chrome.favicons pref is enabled by
default, I think it is important that we add it to the prefs GUI so that people
can turn it off if they dont want to spam servers with favicon requests.
(Assignee)

Comment 1

17 years ago
I am going to try to do this one myself with patchmaker... If I can figure it out :)

CCing Hyatt, cause favicons are his baby.

Comment 2

17 years ago
The favicon pref is not going to be exposed in the GUI.  There is already a pref
in the GUI for disabling/enabling custom icons.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WONTFIX
(Assignee)

Comment 3

17 years ago
Created attachment 57787 [details] [diff] [review]
tasty delicious patch, bet you cant eat just one!

Here is a nice simple patch to add the favicon pref to the gui

It greys-out when the site_icon pref is disabled, and it uses a label that both
the anti-favicon and pro-favicon camps can be happy about: "[X] Aggressively
Seek Icons for All Sites"
(Assignee)

Comment 4

17 years ago
re-opening so I can accept
Status: RESOLVED → UNCONFIRMED
Resolution: WONTFIX → ---
(Assignee)

Comment 5

17 years ago
-> me
Assignee: asa → MozillaUser
(Assignee)

Comment 6

17 years ago
d'oh!

Why cant I accept this bug? I pick "Accept bug (change status to ASSIGNED)" and
hit "Submit" but then it stays "UNCONFIRMED"

Comment 7

17 years ago
Sorry, but producing a patch doesn't mean something necessary gets done...this 
won't be in the UI.  Thanks, though, for making it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → WONTFIX
(Assignee)

Comment 8

17 years ago
uh... yeah...

Can someone please either explain to me the rationalle of leaving this out of
the GUI, or point me towards a bug or document or newsgroup where it has already
been discussed?

I am utterly baffled by this decision.

Comment 9

17 years ago
The favicon implememntation of mozilla uses the link tag as far as I know. IE
way of try anyway even if not mentioned on the webpage isn't used in mozilla as
far as I know. So no pref is needed.
(Assignee)

Comment 10

17 years ago
jesse: Nope, Im afraid not. Mozilla has a pref to enable fetching favicon.ico
from all sites. This pref was originally defaulted to OFF when the site-icons
feature first landed, but now it has been changed to ON by default, so mozilla
is currently requesting favicon.ico from every single site it visits. See bug
109843 for more info on that.
Why doesn't this get a GUI? Because if we added GUI for every little UI nuance
like this, our application would be 90 Mb. I assure you that nobody (*) cares
about toggling this feature on or off. It's either on, or it's off. 

(* - where nobody = 99.99% of users) 
(Assignee)

Comment 12

17 years ago
heh, okay, Im gonna call you on your math here :)

This patch, which adds the gui for one checkbox with conditional disable/enable
javascript adds about 620 bytes to the unjarred chrome. re-jarred, it adds 78 bytes.

According to about:config my mozilla install has 790 prefs. Many of those
already have guis, and many are handled by single guis, for example, 91 of those
are just fonts. 44 are my mail servers. 29 are my mail identities, but just for
the sake of example lets say 790 prefs.

Now this is a pretty simple pref, so lets pretend that the average pref-gui is
ten-times bigger than that. That sounds reasonably over-extreeme. So ~6200 bytes
unjarred and ~ 780 bytes in the jar.

Now if every single one of those 790 prefs gets a gui that big, we bloat the
chrome by 4.9 mb unjarred and 616k in the jar.

Thats all quite a terribly overextreme estimate, but I think it falls a bit
short of 90 megabytes :)

Anyway, this bug doesnt ask for 616k, It asks for 78 bytes. (by way of trivia,
this comment is 1299 bytes)

I would be delighted to rewrite the patch to move the pref into the "Debug"
panel instead of the "Appearance" panel, but I will respect the decision to
WONTFIX this bug, because although I do not know who the appropriate module
owner is, I know it aint me! :)

Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.