Closed Bug 1100769 Opened 7 years ago Closed 6 months ago

Add support for javascript in pdf (eg: animations in pdf presentations) to pdf.js

Categories

(Firefox :: PDF Viewer, defect, P3)

33 Branch
x86_64
Linux
defect

Tracking

()

RESOLVED DUPLICATE of bug 1699219

People

(Reporter: ssameer, Unassigned)

Details

(Whiteboard: [pdfjs-c-feature])

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:33.0) Gecko/20100101 Firefox/33.0
Build ID: 20141013200324

Steps to reproduce:

Open any of these pdfs with javascript animations in Firefox:
http://www.texample.net/tikz/examples/tag/animations/
These are pdf slides from presentations that contain animations:
Click on any link titled pdf in http://www.luatex.org/documentation.html
eg: http://www.luatex.org/talks/screen-justintime-003-tug-2010.pdf


Actual results:

No animations can be seen. Many of the pdfs at texample.net are not correctly rendered either. 


Expected results:

The texample website has images of the correct rendering (as seen in Adobe reader and other viewers). The rendering should match those images. Also, clicking on the buttons in the slides should control the animations.
Component: Untriaged → PDF Viewer
Using latest Nightly 36.0a1 under Ubuntu 12.04 32-bit and Win 7 64-bit, I can see the text on all slides. Clicking on it covers them with a yellow area.

On Chrome, text is not displayed at all, even if it is clicked.
If you open the pdf slides in Adobe reader, the text appears one point at a time, instead of all at once.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P3
Whiteboard: [pdfjs-c-feature]
Status: NEW → RESOLVED
Closed: 6 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1699219
You need to log in before you can comment on or make changes to this bug.