[Flame][Gallery][2.1] Can't switch picture in Gallery if you quickly slide the screen up and down while deleting a picture

RESOLVED WONTFIX

Status

Firefox OS
Gaia::Gallery
--
minor
RESOLVED WONTFIX
4 years ago
3 months ago

People

(Reporter: Sue, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.1 affected, b2g-v2.2 unaffected)

Details

Attachments

(5 attachments)

(Reporter)

Description

4 years ago
[1.Description]:
[Flame][v2.1&v2.2][Gallery] Can't switch picture in Gallery  if you quickly slide the screen up and down while deleting a picture .
Found time:01:00
See attachment: VIDEO_0100.MP4 and logcat_0100.txt

[2.Testing Steps]: 
1.Launch Gallery App.
2.Tap a picture to full screen mode.
3.Switch picture via slide left or right.
4.Tap delete icon and confirm.
5.Slide the screen up and down at the moment when the picture is deleted.
6.Switch picture via slide left or right.

[3.Expected Result]: 
6.Switch function should work normally.

[4.Actual Result]: 
6.Switch function is disabled.

[5.Reproduction build]: 
FLame 2.1 build:
Gaia-Rev        81160ad79e5b4c21967418dd63f1a1d08d77924e
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/3572aa3e6766
Build-ID        20141117001201
Version         34.0

Flame2.2 build:
Gaia-Rev        ae3a84acaab80a5b35d5542d63e68462273c8a1b
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/2d0a51ef828d
Build-ID        20141117160200
Version         36.0a1

[6.Reproduction Frequency]: 
occasionally Recurrence,3/10
(Reporter)

Comment 1

4 years ago
Created attachment 8524460 [details]
logcat
(Reporter)

Comment 2

4 years ago
Created attachment 8524462 [details]
video
Created attachment 8543859 [details]
Flame2.1 logcat

Hi Mike,
This problem is verified NOT to happen on latest Flame 2.2, but it can be repro on latest Flame 2.1. Could you help with it, thanks!
See attachments: Flame2.1_logcat_0324.txt
Reproducing time: 03:24
Reproducing rate: 2/17

Flame 2.1 build
Gaia-Rev        73be51f998031f06db0cd660c0e388fa621c9f4c
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/05dd053f1d90
Build-ID        20150104001209
Version         34.0

Flame 2.2 build:
Gaia-Rev        c2bf20d23851d5fda9f8f0ef0267db5f49152376
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/55f3224d7513
Build-ID        20150104010206
Version         37.0a1
Flags: needinfo?(mlien)

Comment 4

3 years ago
refer to comment 3, change v2.2 to unaffected

Hi Mike, could you help with this, thanks.
v2.2 doesn't have this problem.
status-b2g-v2.2: affected → unaffected
Flags: needinfo?(mlien) → needinfo?(mhabicher)
Tested running:

Gaia-Rev        b04a8cb7b2482e0a44e6702b48c42283a00b5b1e
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/99cea2c818f6
Build-ID        20150107001244
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  65
FW-Date         Mon Dec 15 18:51:29 CST 2014
Bootloader      L1TC000118D0

Observed:

Following the STR, if you swipe up and down ~wildly~ immediately after deleting a photo, the *next* swipe left or right doesn't work. But the swipe after that does.

I don't think this is a major issue; and if encountered, it clears itself up on the next swipe.
Flags: needinfo?(mhabicher)
Summary: [Flame][Gallery]Can't switch picture in Gallery if you quickly slide the screen up and down while deleting a picture . → [Flame][Gallery] Can't switch picture in Gallery if you quickly slide the screen up and down while deleting a picture
Summary: [Flame][Gallery] Can't switch picture in Gallery if you quickly slide the screen up and down while deleting a picture → [Flame][Gallery][2.1] Can't switch picture in Gallery if you quickly slide the screen up and down while deleting a picture
Severity: normal → minor
Created attachment 8570852 [details]
logcat

Hi Mike,
This problem can be repro on latest build of Flame 2.1, is it planned to fix?
See attachments: Flame2.1_logcat_0726.txt
Reproducing time: 07:26
Reproducing rate: 3/15

Flame 2.1 build:
Build ID               20150227002636
Gaia Revision          5d3479fdd438412adee4452720856b6b771fe5cd
Gaia Date              2015-02-25 18:20:09
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/0390c73a827b
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150227.035555
Firmware Date          Fri Feb 27 03:56:06 EST 2015
Bootloader             L1TC000118D0
QA Whiteboard: [MGSEI-Triage+]
Flags: needinfo?(mlien)

Comment 7

3 years ago
Hi Shine, could you also help to verify if this issue can be reproduced on v2.1S?
Since this is a minor and branch specific issue, we may only fixed on partner branch.
Flags: needinfo?(mlien) → needinfo?(yue.xia)
Created attachment 8571184 [details]
2.1s 256m logcat

This problem cannot be repro on 2.1s 512mb, but it can be repro on 2.1s 256mb.
See attachment: 2.1s_256m_logcat_0215.txt
Occurrence time: 02:15
Rate: 3/13

2.1S_512m build:
Build ID               20150301161204
Gaia Revision          a43d64ae01ef108aa4dcc971c770fecd8416a764
Gaia Date              2015-02-26 09:24:39
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1s/rev/2437280c634f
Gecko Version          34.0
Device Name            scx15_sp7715ea
Firmware(Release)      4.4.2
Firmware(Incremental)  122
Firmware Date          Thu Feb  5 12:42:58 CST 2015

2.1S_256m build:
Build ID               20150301161204
Gaia Revision          a43d64ae01ef108aa4dcc971c770fecd8416a764
Gaia Date              2015-02-26 09:24:39
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1s/rev/2437280c634f
Gecko Version          34.0
Device Name            scx15_sp7715ga
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150301.194157
Firmware Date          Sun Mar  1 19:42:09 EST 2015
Flags: needinfo?(yue.xia)

Comment 9

3 years ago
Since current v2.1S project is for 512MB shipping device, this may not need to be fixed.
ni Steven if he has other concerns.

Hi Steven, this issue only can be reproduced on Dolphin v2.1s with 256MB device, do you think we need a patch for v2.1S or wontfix it?
Flags: needinfo?(styang)
I'm curious about if this is relevant to memory. ni? Danny and Chens.
Flags: needinfo?(styang)
Flags: needinfo?(dliang)
Flags: needinfo?(chens)
By logcat, I didn't find any key words regarding oom or memory-pressure-event, so I don't think it's memory issue.

Hi Mike,
I'd like to check memory usage when issue happen, could you help to provide the environment to reproduce this issue?
Thanks,
Flags: needinfo?(dliang) → needinfo?(mlien)

Comment 12

3 years ago
I can reproduce this with Flame v2.1 in 1G memory, thus it maybe not memory issue
Gaia-Rev        a227b67d9ae647cc949ec1ef48ced00c80240025
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/a61c9c3dfba7
Build-ID        20150309161206
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150309.200323
FW-Date         Mon Mar  9 20:03:34 EDT 2015
Bootloader      L1TC000118D0
Flags: needinfo?(mlien)
Flags: needinfo?(chens)

Comment 13

3 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.