Investigate failure in test_browser_navigation.py

RESOLVED WORKSFORME

Status

defect
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: viorela, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Reporter

Description

5 years ago
Posted file logcat
Test test_browser_navigation.py has failed in latest v2.1 build: http://jenkins1.qa.scl3.mozilla.com/job/flame-kk-319.mozilla-b2g34_v2_1.ui.functional.non-smoke/74/HTML_Report/

I couldn't reproduce the issue locally, as I ran the automated test several times.

Traceback (most recent call last):
File "/var/jenkins/2/workspace/flame-kk-319.mozilla-b2g34_v2_1.ui.functional.non-smoke/.env/local/lib/python2.7/site-packages/marionette_client-0.8.3-py2.7.egg/marionette/marionette_test.py", line 171, in run
testMethod()
File "/var/jenkins/2/workspace/flame-kk-319.mozilla-b2g34_v2_1.ui.functional.non-smoke/tests/python/gaia-ui-tests/gaiatest/tests/functional/browser/test_browser_navigation.py", line 27, in test_browser_back_button
browser = search.go_to_url(self.test_url)
File "/var/jenkins/2/workspace/flame-kk-319.mozilla-b2g34_v2_1.ui.functional.non-smoke/tests/python/gaia-ui-tests/gaiatest/apps/search/app.py", line 27, in go_to_url
return search_panel.go_to_url(url)
File "/var/jenkins/2/workspace/flame-kk-319.mozilla-b2g34_v2_1.ui.functional.non-smoke/tests/python/gaia-ui-tests/gaiatest/apps/homescreen/regions/search_panel.py", line 37, in go_to_url
self.keyboard.tap_enter()
File "/var/jenkins/2/workspace/flame-kk-319.mozilla-b2g34_v2_1.ui.functional.non-smoke/tests/python/gaia-ui-tests/gaiatest/apps/keyboard/app.py", line 315, in tap_enter
self.apps.switch_to_displayed_app()
File "/var/jenkins/2/workspace/flame-kk-319.mozilla-b2g34_v2_1.ui.functional.non-smoke/tests/python/gaia-ui-tests/gaiatest/gaia_test.py", line 88, in switch_to_displayed_app
self.marionette.switch_to_frame(self.displayed_app.frame)
File "/var/jenkins/2/workspace/flame-kk-319.mozilla-b2g34_v2_1.ui.functional.non-smoke/.env/local/lib/python2.7/site-packages/marionette_client-0.8.3-py2.7.egg/marionette/marionette.py", line 984, in switch_to_frame
response = self._send_message('switchToFrame', 'ok', element=frame.id, focus=focus)
File "/var/jenkins/2/workspace/flame-kk-319.mozilla-b2g34_v2_1.ui.functional.non-smoke/.env/local/lib/python2.7/site-packages/marionette_client-0.8.3-py2.7.egg/marionette/decorators.py", line 35, in _
return func(*args, **kwargs)
File "/var/jenkins/2/workspace/flame-kk-319.mozilla-b2g34_v2_1.ui.functional.non-smoke/.env/local/lib/python2.7/site-packages/marionette_client-0.8.3-py2.7.egg/marionette/marionette.py", line 621, in _send_message
"Connection timed out", status=errors.ErrorCodes.TIMEOUT)
TimeoutException: TimeoutException: Connection timed out


Build info:
Device firmware (date) 	14 Nov 2014 05:20:26
Device firmware (incremental) 	eng.cltbld.20141114.082015
Device firmware (release) 	4.4.2
Device identifier 	flame
Gaia date 	17 Nov 2014 18:56:59
Gaia revision 	1b231b87aad3
Gecko build 	20141118001204
Gecko revision 	95fbd7635152
Gecko version 	34.0 

We need to still investigate this and try to reproduce the issue.
QA Whiteboard: [fxosqa-auto-backlog+]
Reporter

Comment 1

5 years ago
I was not able to reproduce the issue locally, though I ran the test several times in latest v2.1:

TEST-START | test_browser_navigation.py TestBrowserNavigation.test_browser_back_button
TEST-PASS | test_browser_navigation.py TestBrowserNavigation.test_browser_back_button | took 122712ms

SUMMARY
-------
passed: 41
failed: 0
todo: 0
SUITE-END | took 4881s

Device firmware (date) 	03 Dec 2014 00:49:18
Device firmware (incremental) 	eng.cltbld.20141203.034907
Device firmware (release) 	4.4.2
Device identifier 	flame
Gaia date 	02 Dec 2014 17:43:51
Gaia revision 	dbaf3e31c9ba
Gecko build 	20141203001205
Gecko revision 	ebce587d2194
Gecko version 	34.0

Also, I didn't see this test failing lately. I will close the bug, as it is not reproducible anymore. 
Please reopen if needed.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.