Closed Bug 1101186 Opened 5 years ago Closed 5 years ago

On rebooting the device with Airplane Mode on Gaia sends radio on followed by radio off

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect)

defect
Not set

Tracking

(feature-b2g:2.2+)

RESOLVED FIXED
2.2 S3 (9jan)
feature-b2g 2.2+

People

(Reporter: anshulj, Assigned: eragonj)

References

Details

Attachments

(1 file)

STR:
1. Turn APM on
2. Reboot the device

Observed: Gaia sends a request to turn the radio on and then radio off
Expected: Gaia should send only radio off request.
The issue is that when we reboot with airplane mode on then Gaia asks RIL to first turn the radio on and then radio off. Gaia should not ask to turn the radio on at all.
To use feature b2g instead of blocking flag
blocking-b2g: 2.2? → ---
feature-b2g: --- → 2.2+
Hi Aknow,

after discussed this with Arthur, we remembered that the reason why we have to setRadioEnabled() again on bootup is because if we don't do so, there are some specific tests would be failed when testing. Can we remove this special operation ? If yes, is there any side-effect that we have to take care ? 

Thanks :)
Flags: needinfo?(szchen)
(In reply to EJ Chen [:eragonj][:小龍哥][ni? if you need me] from comment #3)
> Hi Aknow,
> 
> after discussed this with Arthur, we remembered that the reason why we have
> to setRadioEnabled() again on bootup is because if we don't do so, there are
> some specific tests would be failed when testing. Can we remove this special
> operation ? If yes, is there any side-effect that we have to take care ? 
> 
> Thanks :)

Currently, preferences and settings are controlled by gaia. Gecko doesn't know the desired radio state when the phone turns on. So, were you suggesting that gecko should keep the value by itself and set the radio to proper state when boot up?
Flags: needinfo?(szchen)
Assignee: nobody → ejchen
Hi Alive, I just remembered that long time ago, when booting up our phone, Gaia has to send setRadioEnabled to Gecko to notify them do something, do you still remember which part of code would do this thing ?

Anshul's comment #0

> STR:
> 1. Turn APM on
> 2. Reboot the device
> 
> Observed: Gaia sends a request to turn the radio on and then radio off
            ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
> Expected: Gaia should send only radio off request.

I did some greps on system2 but had no luck and can't find any related codes, because you are more familiar with system2, do you know which part of codes would do such things ? Thanks !!
Flags: needinfo?(alive)
It worths to try to change this initial value to undefined
https://github.com/mozilla-b2g/gaia/blob/master/apps/system/js/airplane_mode.js#L36
Flags: needinfo?(alive)
Comment on attachment 8539903 [details] [review]
patch on master

Anshul, can you help me verify whether this patch helps there ? I checked from log and it seems that the second call to Radio has been gone after applying this patch.

Any information would be appreciated !
Flags: needinfo?(anshulj)
Target Milestone: --- → 2.2 S3 (9jan)
feedback ping for Anshul
Flags: needinfo?(anshulj)
Howie, sorry was out of office due to holidays. Would provide an update soon.
Flags: needinfo?(anshulj)
Comment on attachment 8539903 [details] [review]
patch on master

The change is working as expected.
Flags: needinfo?(anshulj)
Attachment #8539903 - Flags: feedback+
Comment on attachment 8539903 [details] [review]
patch on master

Alive, this patch has been verified by Anshul !

Because this is a one-line change and the main problem here is checking the wrong value (undefined v.s. null), I am not quite sure whether we should write a test for such case.

Please help me review this patch and provide some suggestions, thanks :)
Attachment #8539903 - Flags: review?(alive)
Comment on attachment 8539903 [details] [review]
patch on master

Better if having a test in radio_test to test the value is undefined.
Attachment #8539903 - Flags: review?(alive) → review+
Thanks alive, merged into Gaia/master: https://github.com/mozilla-b2g/gaia/commit/0930aeb35b83530a763099b971504e30d1ea149b
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
No longer blocks: CAF-v3.0-FL-metabug
You need to log in before you can comment on or make changes to this bug.